Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
w3c-markup-validator [Le 28/06/2007, 14:41]
82.239.13.25
w3c-markup-validator [Le 19/04/2012, 12:07] (Version actuelle)
109.11.181.206 [Validateur du W3C]
Ligne 1: Ligne 1:
-<​code>​ +{{tag>programmation internet BROUILLON}}
-Ubuntu toutes versions +
-</code>+
  
 Première version rédigée par [[utilisateurs:​antoine|Antoine]] Première version rédigée par [[utilisateurs:​antoine|Antoine]]
Ligne 10: Ligne 8:
  
 Plusieurs validateurs sont installables,​ chacun d'​entre eux a ses avantages et inconvénients,​ à vous de choisir celui qui vous convient (les deux ne signalant pas toujours les mêmes erreurs, ils peuvent s'​utiliser en complément l'un de l'​autre). Plusieurs validateurs sont installables,​ chacun d'​entre eux a ses avantages et inconvénients,​ à vous de choisir celui qui vous convient (les deux ne signalant pas toujours les mêmes erreurs, ils peuvent s'​utiliser en complément l'un de l'​autre).
 +
 +
 +
  
  
Ligne 16: Ligne 17:
 Le [[http://​validator.w3.org|validateur du w3c]] est disponible sous Ubuntu. ​ Le [[http://​validator.w3.org|validateur du w3c]] est disponible sous Ubuntu. ​
  
-Il est nécessaire d'​installer le paquet ''​w3c-markup-validator''​ (le paquet se trouve dans le dépôt ''​universe'',​ il est donc nécessaire [[:​depots#​depots_universe_et_multiverse|de l'​activer]]),​ en utilisant [[:​Synaptic]] ou en ligne de commande. Le validateur nécessite l'​installation du serveur Apache2 ; si celui-ci n'est pas installé, installez en même temps que le validateur le paquet ''​apache2''​.+Il est nécessaire d'​installer le paquet ''​w3c-markup-validator''​ (le paquet se trouve dans le dépôt ''​universe'',​ il est donc nécessaire [[:​depots#​depots_universe_et_multiverse|de l'​activer]]),​ en utilisant [[:​Synaptic]] ou en ligne de commande. 
 +Utilisez ce lien apt si vous êtes sous Gutsy: [[apt://​w3c-markup-validator|installer le paquet w3c-markup-validator]]. 
 +Le validateur nécessite l'​installation du serveur Apache2 ; si celui-ci n'est pas installé, installez en même temps que le validateur le paquet ''​apache2''​.
  
  
Ligne 38: Ligne 41:
   sudo /​etc/​init.d/​apache2 restart   sudo /​etc/​init.d/​apache2 restart
  
-Le validateur est alors accessible à l'​adresse ''​http://​localhost/​w3c-markup-validator/''​. ​+Le validateur est alors accessible à l'​adresse ''​http://​localhost/​w3c-markup-validator/'',​ ou dans les versions ultérieures à l'​adresse ''​http://​localhost/​w3c-validator/''​. ​
  
 Il est aussi possible, par confort, de modifier l'​adresse du validateur, pour avoir par exemple ''​http://​localhost/​validateur/''​ au lieu d'une longue adresse. Pour cela, il faut éditer le fichier ''/​etc/​apache2/​mods-enabled/​w3c.conf''​ et modifier les valeurs des trois premières lignes, pour obtenir par exemple : Il est aussi possible, par confort, de modifier l'​adresse du validateur, pour avoir par exemple ''​http://​localhost/​validateur/''​ au lieu d'une longue adresse. Pour cela, il faut éditer le fichier ''/​etc/​apache2/​mods-enabled/​w3c.conf''​ et modifier les valeurs des trois premières lignes, pour obtenir par exemple :
Ligne 46: Ligne 49:
   Alias /validateur /​usr/​share/​w3c-markup-validator/​html   Alias /validateur /​usr/​share/​w3c-markup-validator/​html
  
 +<​note>​Le validateur w3c utilise les SSI pour rendre les pages HTML. Pour que les SSI fonctionnent,​ il faut activer le module "​include"​ d'​Apache.
 +
 +
 +  sudo a2enmod include
 +
 +
 +</​note>​
  
  
Ligne 61: Ligne 71:
  
   Allow Private IPs 1   Allow Private IPs 1
- 
  
  
  • w3c-markup-validator.1183034486.txt.gz
  • Dernière modification: Le 18/04/2011, 14:39
  • (modification externe)