Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Prochaine révision
Révision précédente
libreoffice_trucs_et_astuces [Le 09/03/2015, 20:05]
L'Africain créée
libreoffice_trucs_et_astuces [Le 29/09/2018, 15:59] (Version actuelle)
L'Africain [Affichage en mode ruban comme pour MSOffice]
Ligne 2: Ligne 2:
  
 ---- ----
 +{{  https://​i2.wp.com/​wiki-astuces.net/​wp-content/​uploads/​2017/​11/​cropped-Wiki-Astuces-Id%C3%A9es-Trucs-et-Astuces-Pratiques-Faciles-et-Utiles-logo.png?​100}}
 ======Trucs et astuces pour utiliser Libreoffice====== ======Trucs et astuces pour utiliser Libreoffice======
  
Ligne 9: Ligne 9:
  
 ===== Compatibilité avec Microsoft Office ===== ===== Compatibilité avec Microsoft Office =====
-Si vous souhaitez travailler sur des documents provenant de (ou à destination de) la suite bureautique Microsoft Office, //consultez le tutoriel **[[:​tutoriel:​compatibilite_openoffice.org_et_msoffice|Comment améliorer la compatibilité entre Libreoffice et MS Office]]**.//​+ 
 +Si vous souhaitez travailler sur des documents provenant de (ou à destination de) la suite bureautique Microsoft Office, //consultez le tutoriel **[[:​tutoriel:​compatibilite_libreoffice_et_msoffice|Comment améliorer la compatibilité entre Libreoffice et MS Office]]**.//​ 
 + 
 +=====Affichage en mode ruban comme pour MSOffice===== 
 + 
 +À partir de la version 5.3 il est possible de modifier l’affichage de LibreOffice pour qu'il ressemble au mode ruban de MSOffice. Pour cela :  
 +  - allez dans **Outils →Option →Avancé** et  
 +  - cochez la case **Activer les fonctions expérimentales** ; Ensuite : 
 +  - Après allez dans **Affichage →Disposition barre d'​outils →Métabarre**. 
 + 
 +<note tip>​Cette procédure désactive par défaut la barre de menus classique. \\ Cliquer sur l’icône en haut à gauche (trois tirets){{https://​i1.wp.com/​kaisman.fr/​mesmots/​wp-content/​uploads/​2015/​07/​classicmenu-indicator_250x155.png?​35}} ​ puis → activer **barre de menus** pour afficher en plus la barre de menus classique.</​note>​ 
 + 
 +Pour réactiver la barre d'​icônes classique, afficher la barre de menu classique et utiliser le menu affichage et décocher l'​option Métabarre.
  
 ===== Numéroter ses pages ===== ===== Numéroter ses pages =====
 +
 ==== Méthode simple et officielle ==== ==== Méthode simple et officielle ====
  
Ligne 37: Ligne 50:
 Si vous disposez d'une [[:tablette graphique]],​ vous pouvez l'​utiliser pour écrire dans un document, par exemple pour y apposer votre signature. Il suffit pour cela de cliquer sur l'​icône « **Afficher les fonctions de dessin** » dans la barre supérieure,​ ou de passer par le menu **Affichage > Barres d'​outils > Dessin**, puis de sélectionner dans la barre qui apparaît l'​outil « **ligne à main levée** ». Chaque trait que vous ferez avec le stylet sera une nouvelle [[http://​fr.wikipedia.org/​wiki/​Image_vectorielle|image vectorielle]]. Si vous disposez d'une [[:tablette graphique]],​ vous pouvez l'​utiliser pour écrire dans un document, par exemple pour y apposer votre signature. Il suffit pour cela de cliquer sur l'​icône « **Afficher les fonctions de dessin** » dans la barre supérieure,​ ou de passer par le menu **Affichage > Barres d'​outils > Dessin**, puis de sélectionner dans la barre qui apparaît l'​outil « **ligne à main levée** ». Chaque trait que vous ferez avec le stylet sera une nouvelle [[http://​fr.wikipedia.org/​wiki/​Image_vectorielle|image vectorielle]].
  
-===== Connecter OOo à des bases de données ​=====+===== Récupérer ses palettes ​de couleurs ou de dégradés ou en utiliser d'​autres ​===== 
 +Dans Libreoffice 5 il est possible d'​ajouter ses propres palettes de couleurs ou de dégradés personnalisés dans **~/​.config/​libreoffice/​4/​user/​config**. 
 +Ces palettes et dégradés seront ainsi disponibles pour tous vos documents.
  
-Pour effectuer un publipostage ou mailing, le paquet [[apt>​libreoffice-base]] doit être installé, faute de quoi les boutons "​définir"​ restent grisés quand on tente de se connecter à un fichier de base de donnée+  * Les palettes de **dégradés** portent l'​extension sog ( **fichier.sog** ). 
 +  * Les palettes de **couleurs** portent l'​extension soc ( **fichier.soc** ). 
 + 
 +Pour connaître ou modifier une palette livrée avec l'​installation de Libreoffice qui se trouve dans **/​usr/​lib/​libreoffice/​share/​palette**,​ utilisez un éditeur de texte. 
 +Faites vos modifications et enregistrez votre palette dans **~/​.config/​libreoffice/​4/​user/​config** en utilisant un nom différent. 
 + 
 +Une explication plus détaillée ici : [[http://​dutailly.net/​creer-une-palette-de-couleurs-pour-libreoffice]] 
 + 
 +=====Se connecter à des bases de données ===== 
 + 
 +Pour effectuer un publipostage ou mailing, le paquet ​**[[apt>​libreoffice-base]]** doit être installé, faute de quoi les boutons "​définir"​ restent grisés quand on tente de se connecter à un fichier de base de données.
  
 Il existe également des extensions pour augmenter la connectivité de LibreOffice. Il existe également des extensions pour augmenter la connectivité de LibreOffice.
  
-==== Avec le pilote JDBC ====+Pour se connecter à une base mysql ou autre [[:​libreoffice_mysql|voir la page décrivant la méthode]], et pour une base [[:​lire_une_base_access|MS Access]]. 
 + 
 +=====Synthèse vocale ​===== 
 +Reportez-vous à la page [[synthese_vocale#​synthese_vocale_dans_libreoffice_ou_apache_openoffice|dédiée]].
  
-Pré-requis : Avoir un environnement java installé. +===== Mettre en place des outils libres capables ​de remplacer Antidote =====
-  * [[:​tutoriel:​comment_installer_un_paquet|Installez le paquet]] **[[apt>​libmysql-java]]** puis redémarrer la session,  +
-  * Dans LibreOffice,​ rendez-vous dans //​Nouveau>​Base ​de données>​Sélectionner "Se connecter à une base de données existante MySQL (et pas jdbc)// +
-  * Cliquez sur //​suivant//,​ puis //Connexion utilisant JDBC (Java Database Connectivity)//​.+
  
 +__Pour remplacer complètement Antidote par des extensions LibreOffice libres et gratuites__,​ il vous suffit d'​__installer les extensions « Pack Grammalecte ≥ 6.2 » ainsi que « Language Tool ≥ 4.0 »__. \\
 +Pour ce faire, __reportez-vous au paragraphe__ [[libreoffice#​Installer des correcteurs|« LibreOffice > Extensions »]] dans cette documentation.
 +=====Autres astuces=====
  
-==== Avec le pilote ODBC ====+Une présentation destinée à montrer l'​utilisation de quelques fonctions pratiques de LibreOffice ("bons usages"​) est disponible [[https://​perso.limsi.fr/​pointal/​divers:​preslibreoffice|ici]].
  
-[[:​openoffice_odbc|Voir la page décrivant la méthode.]] 
  
 ---- ----
  
 //​Contributeurs principaux : [[:​utilisateurs:​OStaquet]],​ [[:​utilisateurs:​Adam0509]],​ [[:​utilisateurs:​Id2ndR]],​ [[:​utilisateurs:​Ner0lph]], ​ [[:​utilisateurs:​poupoul2]],​ [[:​utilisateurs:​psychederic|Psychederic]].//​ //​Contributeurs principaux : [[:​utilisateurs:​OStaquet]],​ [[:​utilisateurs:​Adam0509]],​ [[:​utilisateurs:​Id2ndR]],​ [[:​utilisateurs:​Ner0lph]], ​ [[:​utilisateurs:​poupoul2]],​ [[:​utilisateurs:​psychederic|Psychederic]].//​
  • libreoffice_trucs_et_astuces.1425927911.txt.gz
  • Dernière modification: Le 09/03/2015, 20:05
  • par L'Africain