Résoudre les problèmes rencontrés avec LibreOffice

logo travaux Logo des suites LibreOffice et Microsoft Office

Cette page propose des solutions aux problèmes rencontrés lors de l'utilisation de LibreOffice.

Consultez la page « Advisories-Fr — Messages et bulletins de sécurité », et appliquez les mises-à-jour de versions recommandées. Cette page permet aussi le signalement d'un problème de sécurité.

Les bugs pour Ubuntu sont répertoriés dans Launchpad (en).

Certains problèmes sont dus à des corruptions de fichiers de configuration.
Renommez ~/.config/libreoffice en ~/.config/libreoffice_old.
Au prochain démarrage de LibreOffice, le programme recréera les fichiers de configuration contenus dans ~/.config/libreoffice. Cela s'avère souvent bien plus efficace que de désinstaller / réinstaller le logiciel.

De plus, l'image ISO d'Ubuntu basique est livrée avec une version de la suite LibreOffice concentrée sur les modules essentiels :

  • le module Base est absent, certaines extensions :
    • Presenter Console,
    • PDF import,
    • Report Builder…)

ne sont pas inclus, à la différence du fichier fourni par The Document Foundation.
La version 4.0 én intégrait par exemple certains par défaut1).
Vous trouverez dans le chapitre de cette page une liste plus détaillée.

Enfin, il est souvent possible d'ajouter un dépôt PPA afin d'obtenir une version plus récente de LibreOffice.
Lors de la sortie d'Ubuntu, la version de LibreOffice est souvent issue d'une branche très récente, exemple d'une version x.y.2.
La communauté francophone conseille une utilisation à partir d'une version de type x.y.3, voire la x.y.42) Pour installer le ppa, suivez le chapitre, « installer le ppa » de la page sur LibreOffice.

Certains problèmes déjà répertoriés avec OpenOffice.org subsistent, notamment ceux évoqués dans les sections suivantes.

Virgule et pavé numérique

Le problème est toujours présent dans LibreOffice 6.0.3 sous Ubuntu 18.04 LTS.

Dans le tableur Calc, la touche de séparateur décimal du pavé numérique donne un point au lieu d'une virgule (voir sur Launchpad).

Ce bug concerne la configuration de clavier « Français (variante) ». Il s'agit de celle installée par défaut.

Ce bug ne concerne pas les configurations « Français » et « Français (variante obsolète) » (testé pour Ubuntu 12.04 LTS et 14.04 LTS).

Si l'une des deux dernières configurations vous convient, voici comment changer de configuration clavier :
  • Aller dans Paramètres Système → Saisie de texte
  • Cliquer sur le bouton « + » pour ajouter le clavier « Français » et supprimer le clavier « Français (variante) » à l'aide du bouton « - »

Si vous souhaitez utiliser la configuration par défaut « Français (variante) », lire ce qui suit.

Trois méthodes sont proposées ci-dessous.
Les deux premières (au choix) permettent de rétablir la virgule. La troisième permet de faire en sorte que le point soit interprété comme séparateur décimal.

Première méthode : par le menu « Système »

Cette méthode est recommandée

Gnome sur Ubuntu 18.04

Les options ne sont plus disponibles dans Paramètres système ; Gnome a — en effet — été « simplifié »…

  • lancer gnome-tweaks ("Ajustements");
  • aller sur l'onglet "Clavier & souris"
  • ouvrir "options supplémentaires d'agencement"
  • développer Comportement de la touche Suppr. du clavier numérique ;

À partir d'ici, il existe deux solutions :

Solution n°1 :

  • sélectionnez l'option « Touche obsolète avec point » : permet d'avoir une virgule avec LibreOffice et un point dans les autres applications;
  • modifier les options de libre office comme indiqué à la 3e méthode

Solution n°2 :

  • sélectionnez l'option « Touche obsolète avec virgule » : permet d'avoir une virgule à la place du point dans toutes les applications. Ne nécessite pas de modification des options de LibreOffice.
Unity sous Ubuntu 14.04 LTS et 16.04 LTS

Les options ne sont plus disponibles dans Paramètres système (Gnome a été « simplifié »…).

  • lancer gnome-tweak-tool ("Outil de personnalisation");
  • aller sur l'onglet « Typing » —{« Saisie »} ;
  • développer disposition du pavé numérique ;
  • sélectionnez l'option « Obsolète ».
Le bureau MATE
  • Allez dans le menu Système → Préférence → Clavier, onglet « Agencements » ;
  • sélectionner l'agencement « France Autre » dans la liste ;
  • cliquer sur le bouton « Options de l'agencement… » ;
  • développez Comportement de la touche de suppression du clavier numérique ;
  • sélectionnez l'option « Touche obsolète avec point » ;
    • l'option permet d'obtenir une virgule dans LibreOffice et un point partout ailleurs ;
    • l'option « Touche obsolète avec virgule » provoque l'activation de la virgule de façon globale.
Le bureau Xfce

Pour 18.04 et 19.10, il n'y a pas d'option disponible dans l'agencement du clavier. Par ailleurs l'usage de l'utilitaire gnome-tweaks est sans effet dans cet environnement. Cependant, il existe une solution en éditant le fichire ~/.profile

Dans un terminal, tapez la commande :

nano ~/.profile

ou utilisez votre éditeur de texte favori. Ajouter la ligne dans le fichier :

setxkbmap -option '' -option kpdl:comma

puis se déconnecter et rouvrir la session.

Deuxième méthode à laide du fichier Xmodmap

Installer et configurer un fichier .Xmodmap afin de corriger la définition du clavier.
Vous pouvez :

  • rendez ce fichier exécutable (avec Nautilus, clic droit → propriétés → Permissions → Exécuter comme un programme).
  • lancez le script dans une console :
cd ../..
home/nom_dutilisateur/.Xmodmap

Si tout s'est bien passé, automatisez le script au démarrage : en faisant une recherche avec le mot clé "Démarrage" dans votre tableau de bord, puis ajoutez :

  • Nom : Virgule LO
  • Commande : home/nom_dutilisateur/.Xmodmap

Source

troisième méthode

À la différence des méthodes précédentes, celle-ci ne remplace pas le point par une virgule, elle utilise le point comme séparateur décimal.

Elle a été proposée sur le forum. Elle est à utiliser si la touche décimale (le point) du pavé numérique est mal interprétée ; c'est-à-dire lorsqu'elle est considérée comme un point et non comme un séparateur décimal (virgule en France).

Dans LibreOffice, sélectionner Options → Paramètres linguistiques → Langues :

  • Interface utilisateur : par défaut
  • Environnement linguistique : Anglais (Royaume-Uni)

Ensuite, cochez Touche séparateur de décimales identique au paramètre linguistique.

Les dates seront également modifiées en conséquence pour s'adapter à l'affichage anglais du Royaume-Uni tel que défini dans l'environnement linguistique.
L'environnement linguistique Français (Suisse) fait la même chose, et il offre une meilleure compatibilité quant aux formats de dates. On peut en outre dans le tableur sélectionner les formats de date, monétaires ou numérique pour qu'ils s'affichent à la française en choisissant dans l'option de cellule la langue française(FR). Un autre avantage de cette méthode est de pouvoir garder un agencement de clavier France-autre qui permet, entre autre, un accès simple aux caractères œ et Œ.

La gestion du chiffrement des fichiers (enregistrement avec mot de passe) a changé depuis LibreOffice 3.5. LibreOffice 3.5 peut ouvrir les fichiers enregistrés avec mot de passe dans une version antérieure. Par contre, les fichiers enregistrés avec mot de passe par une version 3.5 ne peuvent être ouverts qu'avec une version 3.4.5 ou supérieure. Si vous avez LibreOffice 3.4.4 ou antérieure, cela ne fonctionnera pas, il faut installer une version supérieure.

Lors de l'ouverture de classeur (fichier ods et odt), si vous rencontrez le message d'erreur suivant :
Erreur de lecture une erreur inconnue s'est produite, cela peut-être dû à un fichier corrompu suite à une mise-à-jour depuis OpenOffice ou une installation incomplète.
Il existe deux solutions différentes selon l'origine du problème. Vérifiez le fonctionnement de la solution choisie en ouvrant de nouveau le fichier incriminé. Si votre problème n'est pas résolu, appliquer la solution suivante.

Nettoyez votre profil utilisateur

  1. Fermez LibreOffice et le « Démarrage rapide » si vous l'avez installé ;
  2. Affichez les fichiers caché de votre répertoire personnel et renommez le répertoire .config/libreoffice en .config/oldlibreoffice ou supprimez-le.

Si le problème n'est pas corrigé, appliquez la solution suivante.

Réinstallez LibreOffice

Supprimez le paquet libreoffice et toutes ses dépendances pour les réinstaller. Consultez les rubriques désinstallation et installation de cette page pour obtenir plus d'informations.
Suite à cette manipulation, votre problème sera très certainement résolu. Dans le cas contraire, consultez la communauté francophone de LibreOffice.

la version 3.3

Constaté avec la version 3.3 depuis les paquets fournis sur le site.

Lors de la tentative de lecture d'un fichier sur NFS, la bannière de présentation de LibreOffice se lance et le système plante. Ouvrez le fichier :usr/lib/libreoffice/program/soffice avec les droits d'administration et commentez la ligne suivante (mettre un # devant la ligne) :

export SAL_ENABLE_FILE_LOCKING

LibreOffice dans la version pré-installée avec Ubuntu, ne semble pas contenir les outils nécessaires au publipostage. Afin de pouvoir profiter pleinement des ressources de publipostage, il faut installez le paquet : libreoffice-base.

Dans certains cas de figure, la procédure d'installation produit une configuration défectueuse.
Le module Base fonctionne, éxcepté la gestion des rapports.
Il peut dès lors s'avérer nécessaire d'effectuer une installation globale "hors PPA".
Voir https://forum.openoffice.org/fr/forum/viewtopic.php?f=9&t=48561

Si vous recevez des diaporamas par e-mail (souvent des fichiers .pps créés avec Microsoft Powerpoint) vous n'entendrez pas de son si vous avez une installation standard d'Ubuntu.

En effet, certains paquets supplémentaires sont nécessaires pour cette fonctionnalité mais ne sont pas installés par défaut car certains composants sont non libres (ou moins libres) :

Pour certains fichiers au format *.PPS3), l'installation du paquet gstreamer0.10-ffmpeg semble résoudre les problèmes de son.4)

(Fonction accessible par le menu Fichier > Envoyer ou par un bouton de la barre d'outil principale.)

L'erreur stipule que Libreoffice ne trouve pas le client mail, c'est visiblement dû à un mauvais paramétrage du client mail par défaut.
Ou bien un nouveau courriel s'ouvre bien mais la pièce jointe ne s'y trouve pas (LibreOffice 4.0.1. sous Ubuntu 12.04).

Résolution : aller dans le menu Outils > Options > Internet > E-mail.

  • Saisissez thunderbird ou
    • utiliser le bouton qui permet de naviguer pour trouver un autre exécutable (par exemple dans /usr/bin, puis
  • sélectionner "thunderbird").
  • Valider par OK.

Constaté dans LibreOffice Calc 4.0.1 sous Ubuntu 12.04, toujours présent dans 4.3.4 sous Ubuntu 14.04.

Dans une cellule ou une URL a été saisie (et transformée en hyperlien), si on rajoute par la suite du texte dans la cellule en utilisant la touche majuscule dans la zone de saisie, l'URL perd sa qualité de lien dynamique ou bien se brise. Il peut arriver qu'une partie du texte saisi par la suite s'insère au milieu de l'hyperlien.

illustration du bogue « texte dans un hyperlien »


Dans l'exemple ci-contre, le texte ajouté après le lien dynamique est <espace>HORREUR<espace>123456. Les chiffres se sont insérés au milieu du lien.

On en discute sur le forum : « Bug LibreOffice Calc : texte s'insère au milieu des URL »


Contournement : effectuer la saisie directement dans la cellule (mode saisie activé par un double-clic dans la cellule).

Les commentaires dans les fichiers au format xls (format de fichier créé par excel) ne sont pas visibles. La couleur du commentaire est blanche sur un fond jaune. Il faut corriger la couleur de la police du commentaire.

[Upstream] VIEWING: Comments are not readable (shown in white over yellow)

Si vous avez l'erreur ci-dessous :

[Java framework] Error in function createSettingsDocument (elements.cxx).
javaldx failed! 
Warning: failed to read path from javaldx
terminate called after throwing an instance of 'com::sun::star::uno::RuntimeException'

Il vous faut redonner le bon propriétaire au dossier .config/libreoffice/.
Pour cela, tapez dans un terminal la ligne suivante en remplaçant user par votre nom d'utilisateur.

sudo chown user:user -R .config/libreoffice/ 

Il se peut que lors de l'impression certaines polices soient altérées. Cela est du à un mauvais paramétrage du type de langue de l'imprimante, dans les options du périphérique d'impression qui sont sur pdf. Or ils doivent être sur PostScript. Pour modifier cela suivez cette procédure:

  • Entrer cette commande dans un terminal:
    sudo /usr/lib/libreoffice/program/spadmin
  • Cocher "Désactiver la prise en charge CUPS",
  • Puis Propriétés>Périphérique>PostScript niveau 2,
  • Décocher "Désactiver la prise en charge CUPS".

Ceci permet de conserver le choix qui, sinon, revient à "PDF" à chaque nouvelle ouverture d'un fichier LibreOffice.

Si votre correcteur orthographique ne fonctionne pas automatiquement

  1. vérifiez en premier lieu que l'icône avec le logo ABC est bien activée,
  2. puis vérifiez que les paquets suivants sont bien installés : hyphen-fr,mythes-fr,hunspell-fr.

Lorsque l'on veut glisser un lanceur d'un des modules de Libreoffice sur le bureau, cela ne fonctionne pas. Pour remédier à ce problème il faut créer le lanceur manuellement. Entrez cette commande dans un terminal:

gnome-desktop-item-edit --create-new ~/Bureau
  • Dans la case "nom" renseignez le nom que vous souhaitez donner au lanceur en fonction du module (par exemple "Writer" pour le traitement de texte).
  • Dans la case "commande" entrez: libreoffice –writer %U, vous devrez adapter writer à votre module,
  • Dans "commentaire", mettez ce que vous voulez pour décrire à quoi sert l'application.
  • Enfin cliquez sur l'icône et naviguez jusqu'à l'icône correspondante à votre module. Les icônes se trouvent dans le dossier /usr/share/icons/gnome/48x48/apps/.

Si vous rencontrez des lenteurs par exemple pendant la saisie du texte, il est possible qu'il faille augmenter l'allocation de la mémoire pour LibreOffice.
Pour cela allez dans Outils → Options → Mémoire et dans Utiliser pour LibreOffice passez de 20 à 96.

Concernant Libreoffice 6 : un bug a fait disparaitre cet option, il faut y aller manuellement comme indiqué dans le rapport de bug.

Un problème existe sous Xfce et Lxde (et peut être d'autres environnements), il est impossible d'ouvrir un document qui n'est pas local (exemple : réseau SMB).

Pour corriger ce problème il suffit d'installer le paquet libreoffice-gnome (n'a pas fonctionné sous lxde, à tester ou trouver une autre solution).

Constaté en septembre 2018 sur un Xubuntu 18.04 (mis à niveau depuis 16.04) : LibreOffice 6.0 (l'écran menu) se lance, mais après avoir cliqué sur Writer tout se ferme. Idem sous Terminal, aucun message d'erreur. Note: les autres modules de LibreOffice (ex: Calc) fonctionnent.

Contournement: désactiver Java. Pour cela lancer Libreoffice, menu "Outils", "Options", puis sous la section LibreOffice cliquer "Avancé". Désélectionner "Utiliser un environnement Java" (10.x dans notre cas).

Sous Ubuntu 18.04 avec Unity 7 LibreOffice 6 affiche en haut à droite Unknown Application. Pour résoudre ce problème, il est necessaire de modifier le lanceur :

  • Ouvrez le fichier /usr/share/applications/libreoffice-writer.desktop avec les droits d'administration (à faire pour tous les modules de la suite, calc, draw, etc),
  • Modifiez la ligne exec pour qu'elle ressemble à ceci Exec=env XDG_CURRENT_DESKTOP=Unity libreoffice –writer %U adaptez ceci à chaque module de LibreOffice.

Le rapport de bug se trouve sur cette page.

Sous LibreOffice 6.4 avec Xubuntu 19.10, le format par défaut est le format américain « Lettre » de 27,9 × 22 cm (utilisé en Amérique du nord, dans la plupart des pays d'Amérique centrale, au Chili et aux Philippines) au lieu du format international d'origine allemande ISO A4 (le célèbre « vingt-et-un vingt-neuf sept » des familles), utilisé dans le reste du monde.

Si la différence peut paraître minime au premier abord, cela peut poser des problèmes à l'impression, car la majorité des imprimantes européennes ou africaines utilisent du papier A4. À l'impression, le logiciel transposera vos éléments pour les faire rentrer sur une feuille A4, mais la taille du résultat sera alors différente de ce qui apparaît à l'écran. Le meilleur moyen de se endre compte de ce défaut est de créer un document Writer vide, de régler le zoom à 110 % et de placer une feuille de votre imprimante sur votre écran. Si vous êtes en format A4, la feuille devrait suivre parfaitement les bords de votre document ; si ce dernier dépasse de la feuille, vous êtes en format « Lettre ». On peut alors bien voir la différence de taille entre ces deux formats.

Pour régler ce problème, ouvrez la fenêtre Outils → Options, puis dans la liste Paramètres linguistiques, cliquez sur Langue. Changez la valeur Paramètres locaux de Par défaut − Français (votre pays) à Français (votre pays).

Tous les documents que vous créerez après cette manipulation seront en format A4 ; cependant, ce que vous avez créés antérieurement sont toujours au format « Lettre ». Pensez à bien vérifier le format de vos anciens douments.
Au Canada, le format standard utilisé par les imprimantes est le format américain. Les paramètres locaux Français (Canada) sont à disposition des utilisateurs Québécois5). Le format de date sera également modifié, de même que les champs de monnaie s'afficheront en dollars canadiens au lieu d'en euros.

Pour régler ce problème, installer le paquet :

Discussion sur cette page sur le forum.


Contributeurs principaux : GeekShadow, Gemnoc, McPeter, gguillaume017, mohican, L'ami René, dolmen, L'Africain .


  • libreoffice_problemes.txt
  • Dernière modification: Le 09/08/2020, 20:43
  • par eagle08