Contenu | Rechercher | Menus

 Logo de LibreOffice

LibreOffice

LibreOffice1) est une suite bureautique libre, gratuite, multiplateforme et complète (traitement de texte, tableur, logiciel de présentation, etc.), ce qui fait d'elle une excellente alternative aux suites bureautiques propriétaires telles que Microsoft Office, Microsoft Office Online, Google Docs, …

C'est une suite logicielle très modulaire : des extensions, des modèles, des images, des thèmes, des polices sont librement mis à disposition par la communauté.

Sur la plupart des variantes d'Ubuntu, LibreOffice est installé en tant que suite bureautique par défaut.

  • Bien vérifier la version de LibreOffice qui s'est installée, surtout si vous souhaitez la version stable ! Ouvrez LibreOffice puis Aide → À propos de LibreOffice pour voir votre version installée.
  • Regarder sur le site de LibreOffice le numéro de la dernière version stable.

Licences

D'un point de vue légal, LibreOffice est distribué sous les licences libres MoPL V2, Licence Apache 2.0 pour le code basé sur Apache-OpenOffice et diverses autres licences open source.

LibreOffice est un embranchement (ou fork) de la suite libre de bureautique OpenOffice.org, développée par The Document Foundation, une fondation regroupant la communauté de développeurs d'OpenOffice.org ainsi que différents partenaires comme la FSF, OASIS, Google, Novell, Red Hat, Canonical, OSI, …

Autres remarques et alternatives 

  • LibreOffice est une suite bureautique complète. Si vous cherchez simplement à pouvoir lire et modifier des documents de type texte formaté (.doc, .odt) et des feuilles de tableur (.xls, .ods), le couple Abiword + Gnumeric peut être une alternative intéressante car plus légère si vous êtes dans un environnement GTK+ (c'est le cas d'Ubuntu et de Xubuntu) ou Calligra Words + Calligra Cells si vous utilisez un environnement en Qt (par exemple Kubuntu).
  • LibreOffice prend notamment en charge les formats Open XML de Microsoft Office (.docx, .xlsx, .pptx), mais peut avoir des difficultés à les lire. Il est préférable de lire/modifier ces types de fichiers avec les logiciels de Microsoft ou de les enregistrer dans les anciens formats de Office (antérieurs à 2007 : .doc, .xls, .ppt) qui sont mieux pris en charge par LibreOffice.
    Il en est de même si vous souhaitez lire un fichier .odt avec Word par exemple.
  • Il est par contre toujours possible d'utiliser le successeur d'OpenOffice, en installant Apache OpenOffice, même si cette solution ne présente aucun intérêt notable ; au contraire, LibreOffice supporte davantage de configurations des formats propriétaires Microsoft, comme l'intégration et la lecture possible des formules de MS Word & Excel, ou la reconnaissance et la lecture des documents MS Office enregistrés avec protection mot de passe.
  • Il existe aussi le fork allégé, totalement libre, basé sur OpenOffice.org, OOoLight, créé par l'association à but non lucratif EducOOo.

Pré-requis

Pour la méthode recommandée, il faut disposer des droits d'administration et d'une connexion à Internet configurée et activée.

Pour la méthode par appimage, aucun pré-requis n'est nécessaire.

Installation

Méthode recommandée

LibreOffice est installé par défaut sous la plupart des variantes d'Ubuntu. Pour installer LibreOffice quand il n'est pas installé, ou pour réinstaller LibreOffice, installez les paquets suivants :

Recherchez simplement "LibreOffice" dans la logithèque et installez ce qui vous convient.

Les paquets des langues de votre système seront aussi installées. Si ce n'était pas le cas, pour le français, installez les paquets libreoffice-l10n-fr libreoffice-help-fr hyphen-fr

Les extensions incluses dans LibreOffice

La version provenant du site Libreoffice donne une liste de 6 extensions que l'on peut ou non installer (cochés par défaut), mais elles ne sont pas disponibles sur son site. Pour les retrouver dans la logithèque vous tapez libreoffice extension ; sinon voici le nom de chacune et le nom de son paquet :

Il peut arriver que le paquet libreoffice-nlpsolver installé après coup ne soit pas actif. Dans ce cas il semble nécessaire de désinstaller puis de réinstaller libreoffice avec la commande suivante dans un terminal:
sudo apt-get purge libreoffice* && sudo apt-get install libreoffice libreoffice-nlpsolver libreoffice-help-fr libreoffice-l10n-fr

Autres exemples d'extensions installables

Les styles d'icônes incluses dans LibreOffice

Pour des questions de place, seul un ensemble restreint de jeux d'icônes est inclus dans la version fournie par Canonical par rapport à la version fournie par The Document Fondation. Elles peuvent être retrouvées en tapant les mots libreoffice-style dans la logithèque, sinon voici la liste complète :

Au format appimage

Article dédié au fonctionnement de cette méthode : appimage.

Les fichiers se trouveront sur ce site.

Avec Flatpak (Ubuntu ≥ 16.04)

Articles dédiés : flatpak, tutoriel pour l'utiliser.

Depuis cette page de leur site, suivez les instructions qui vous concernent pour installer LibreOffice selon le niveau de privilèges qui vous convient.

Avec Snap (Ubuntu ≥ 16.04)

Article dédié : snap.

Ouvrez un terminal et entrez la commande suivante en tant qu'administrateur :

snap install libreoffice

Avec les PPA

Ce dépôt PPA maintenu par les développeurs de LibreOffice permet d'obtenir une version stable relativement récente par rapport à celle des dépôts officiels.

Une version de LibreOffice est considérée comme stable (donc recommandée pour une utilisation dans un contexte professionnel) à partir de sa 4e révision , soit la 5.3.4 Une version admissible, généralement désignée par le terme anglais Release Candidate (souvent abrégé en RC)

Les versions X.X.X~rc2 sont en général identiques à la version finale. Contrairement aux builds officielles, les PPA ne les renomment alors pas comme telles.

Version d'Ubuntu Version installée Version du PPA 5.3Version du PPA 5.4 Version du PPA générique Version du PPA pré-versions
Ubuntu 17.04 5.3.1 5.3.5~rc2 5.4.0~rc3 5.3.4~rc2 5.4.1~rc1
Ubuntu 16.04 LTS 5.1.6 5.3.5~rc2 5.4.0~rc3 5.3.4~rc2 5.4.1~rc1
Ubuntu 14.04 LTS 4.2.8 5.3.5~rc2 5.4.0~rc3 5.3.4~rc2 5.4.1~rc1

(informations à jour le 12/08/2017)

Versions stables

Ces PPA contiennent la dernière version de la branche (ou de toutes les branches pour le PPA générique), ou éventuellement la release candidate prévue pour être la version finale (RC2). Les paquets présents dans le dépôt PPA générique sont accessibles ici, vous y trouverez également un lien vers les dépôts de chacune des branches (actuellement : 5.3 et 5.4).

 Avant d’aller plus loin, veuillez noter que les paquets sur le PPA n'ont subi que des tests minimaux. Cette mise à jour est réservée aux utilisateurs sachant utiliser ppa-purge pour annuler les modifications si quelque chose venait à ne plus fonctionner comme il le faut. Cependant, cela est plus sûr que d'utiliser directement les fichiers .deb fournis par The Document Foundation.
Méthode graphique
  • Pour la version 5.3 Version "Stable", utilisable par tous, y compris dans un cadre professionnel : ppa:libreoffice/libreoffice-5-3 2)
  • Pour la version 5.4 Version "Évolution" destinée aux utilisateurs avancés souhaitant tester les nouveautés de LibreOffice : ppa:libreoffice/libreoffice-5-4 3)
  • Pour la dernière version du PPA générique :(permet de rester à jour sans avoir à changer de branche): ppa:libreoffice/ppa4)
  1. Pour chaque langue installée sur votre système et/ou pour laquelle vous désirez l'aide, installez le paquet d'internationalisation libreoffice-l10n-XX, par exemple pour fr : libreoffice-l10n-fr;
Méthode en ligne de commande

Ouvrez un terminal et entrez les commandes suivantes pour la branche 5.3 :

sudo add-apt-repository ppa:libreoffice/libreoffice-5-3

Pour la branche 5.4 :

sudo add-apt-repository ppa:libreoffice/libreoffice-5-4

Pour la branche générique :

sudo add-apt-repository ppa:libreoffice/ppa

Puis dans les trois cas :

sudo apt-get update
sudo apt-get install libreoffice

Pré-versions (alpha, béta, RC1)

Conçu seulement pour les testeurs…
Méthode graphique
Méthode en ligne de commande

Ouvrez un terminal et entrez les commandes suivantes :

sudo add-apt-repository ppa:libreoffice/libreoffice-prereleases
sudo apt-get update
sudo apt-get install libreoffice

Via les fichiers .deb

Cette méthode est plus complexe, et n'apporte pas d'avantages.

Installation de la suite bureautique

Il est possible d'installer LibreOffice à partir des paquets deb proposés sur le site du projet, paquets qui sont disponibles pour les architectures 32 et 64 bits.

Le site vous propose automatiquement les paquets à télécharger en fonction de la configuration de l'ordinateur avec lequel vous consultez le site (système d'exploitation, architecture, langue ; par exemple "linux x86 (deb)" et "fr-Français"). Vérifiez que cette configuration correspond bien à l'ordinateur sur lequel vous allez faire l'installation.

Si vous ne savez pas si vous êtes en 32 ou 64 bits, reportez-vous à la documentation sur l'architecture matérielle.

Décompressez l'archive puis ouvrez un terminal dans le répertoire d'installation, et installez l'ensemble des archives .deb qui y sont présentes :

sudo dpkg -i *.deb

Installation de l'interface en français

La méthode décrite ci-dessous ne fonctionne pas pour xubuntu 14.04 (problème avec libobasis). Il faut installer le paquet libreoffice-l10n-fr et l'interface est en français au redémarrage de libreoffice !

Il vous suffit d'utiliser le paquet LibO_xxxxxxxxxxxx_langpack-deb_fr.tar.gz téléchargé à l'étape précédente.

Ensuite extrayez l'archive, placez-vous dans le dossier et installez l'ensemble des fichiers .deb

cd LibO_xxxxxxxxxxxx_langpack-deb_fr/DEBS
sudo dpkg -i *.deb

Au prochain lancement, LibreOffice sera en français.

Installation de l'aide en français

Il vous suffit d'utiliser le paquet LibO_xxxxxxxxxxxx_helppack-deb_fr.tar.gz téléchargé précédemment.

Ensuite extrayez l'archive, placez-vous dans le dossier et installez l'ensemble des fichiers .deb

cd LibO_xxxxxxxxxxxx_helppack-deb_fr/DEBS
sudo dpkg -i *.deb

Configuration

Accélérer LibreOffice

Extensions

* Téléchargez l'extension (Enregistrer sous).

  • Allez dans Outils → Gestionnaire des extensions puis cliquez sur le bouton « Ajouter »
  • Sélectionnez l'extension, puis cliquez sur le bouton « Ouvrir ».

Pour les extensions se trouvant dans les dépôts, il suffit d'installer les paquets en question.

Extensions pour l'éducation

Installer des correcteurs

Pour indiquer à LibreOffice dans quelle langue est le document courant, sélectionner la langue via Outils / Langues / Pour le texte… (sélectionner Français). Noter qu'il est possible de changer la langue d'un groupe de mots seulement (phrase, paragraphe…). Pour lancer une passe de correction orthographique manuelle, sélectionner le menu Outils / Orthographe et grammaire (accès direct par F7).

Les fonctionnalités de correction orthographique et grammaticale en français sont disponibles sous la forme d'extension à installer manuellement. Le plus simple est de récupérer l'orthographe et/ou la grammaire sur Grammalecte.

Il se peut que LibreOffice plante à l'installation de Grammalecte. Vérifiez que vous disposez du paquet python3-uno puis lancez la commande export dans un terminal avant de lancer LibreOffice afin que celui-ci ait accès à la bibliothèque python "uno.py" :

export PYTHONPATH=/usr/lib/libreoffice/program:/usr/share/pyshared
libreoffice &
Le correcteur orthographique alternatif LanguageTool également disponible comme extension pour LibreOffice, n'est pas compatible avec Grammalecte, n'utilisez donc pas ces deux extensions ensemble.

Dans le cas de l'installation d'une version récente de LanguageTool il est nécessaire d'installer libreoffice-java-common, openjdk-8-jre et de le choisir dans Outils > Options > Avancé > Paramètres, choisir Oracle Corporation.

Vignettes d'aperçu dans votre navigateur de fichiers

Les méthodes ci-dessous vont permettront d'afficher dans votre navigateur de fichiers les miniatures des fichiers OpenDocument.

Méthode Nautilus Thunar Dolphin Nemo Caja PCManFM
Paquet ooo-thumbnailer Fonctionne Incompatible→voir ici Incompatible→voir ici Fonctionne Fonctionne Non testé
Script Nicolas Bernaerts Fonctionne Incompatible Incompatible Fonctionne Fonctionne Fonctionne
PPA Atareao Fonctionne Incompatible Non testé Fonctionne Non testé Non testé

Méthode 1 : grâce à ooo-thumbnailer

Installez le paquetooo-thumbnailer

Cependant, il arrive qu'un bogue empêche son bon fonctionnement, voici comment le régler :

usr/share/thumbnailers/ooo.thumbnailer>[Thumbnailer Entry]

TryExec=ooo-thumbnailer
Exec=/usr/bin/ooo-thumbnailer %i %o %s
MimeType=application/vnd.oasis.opendocument.graphics;application/vnd.oasis.opendocument.presentation;application/vnd.oasis.opendocument.spreadsheet;application/vnd.oasis.opendocument.text;
  • Sauvegarder le fichier et redémarrer Nautilus :
nautilus -q

Méthode 2 : grâce à un script de Nicolas Bernaerts

Il est possible de faire afficher des vignettes d'aperçu dans le navigateur de fichiers, grâce à un script de Nicolas Bernaerts

Là où ooo-thumbnailer se contente de produire des versions miniatures des documents en guise d'icônes (comme pour les images ou les fichiers PDF), le script ajoute des captures d'écran avec des petites logos distinctifs en surimpression des miniatures de manière à reconnaître facilement le type de fichier (ce qui pourra être un avantage ou inconvénient selon les goûts).

Méthode en ligne de commande
sudo apt-get install gvfs-bin libfile-mimeinfo-perl unzip imagemagick
wget --header='Accept-Encoding:none' https://raw.githubusercontent.com/NicolasBernaerts/ubuntu-scripts/master/thumbnailer/libreoffice/lo-thumbnailer-install.sh
. ./lo-thumbnailer-install.sh
rm -r $HOME/.cache/thumbnails
nautilus -q

Vous devriez obtenir le résultat suivant :

(Pour vignettes des documents MS Office)

Méthode 3 : via un PPA de l'équipe Atareao

L’équipe atareao a développé des extensions qui permettent d’afficher les miniatures pour ces formats de fichiers dans Nautilus (dont les vignettes pour LibreOffice)

Pour l'installer :

Pour appliquer les modifications, enlever les caches miniatures et redémarrer Nautilus en exécutant les commandes ci-dessous :

rm ~/.cache/thumbnails/fail/gnome-thumbnail-factory/*
rm ~/.cache/thumbnails/large/*
rm ~/.cache/thumbnails/normal/*
killall nautilus

Créer un document depuis le navigateur de fichiers

Le nouveau document est créé à partir d'un modèle déjà enregistré dans le dossier ~/Modèles.

Plus de détails dans ce tutoriel.

Changer le(s) modèle(s) par défaut

1. Créer un document [classeur, présentation, dessin] conforme à ce qu’on souhaite avoir par défaut. En particulier définir la police du ou des styles qui s’appellent « Par défaut ».

2. menu Fichier > Enregistrer comme modèle : l'enregistrer dans le dossier « Mes Modèles » avec le nom qu'on souhaite.

3. Procéder comme suit pour définir ce nouveau modèle comme étant le modèle par défaut :

Ajouter des raccourcis d'accès

Ces consignes s'appliquent pour Unity et GNOME Shell.

À chaque mise à jour de LibreOffice, l'opération est à recommencer.

Pour pouvoir ajouter des Quicklist à LibreOffice sur le lanceur, il faut préalablement placer l'application LibreOffice sur le lanceur.

Il faut ensuite modifiez le fichier /usr/share/applications/libreoffice-startcenter.desktop avec les droits d'administration et y copier le contenu suivant à la fin du fichier ouvert :

X-Ayatana-Desktop-Shortcuts=Writer;Calc;Impress;Base;Draw;Math
 
[Writer Shortcut Group]
Name=Nouveau document texte
Exec=libreoffice -writer %U
TargetEnvironment=Unity
 
[Math Shortcut Group]
Name=Formule mathématique
Exec=libreoffice -math %U
TargetEnvironment=Unity
 
[Impress Shortcut Group]
Name=Nouvelle présentation
Exec=libreoffice -impress %U
TargetEnvironment=Unity
 
[Draw Shortcut Group]
Name=Nouveau dessin
Exec=libreoffice -draw %U
TargetEnvironment=Unity
 
[Calc Shortcut Group]
Name=Nouvelle feuille de calcul
Exec=libreoffice -calc %U
TargetEnvironment=Unity
 
[Base Shortcut Group]
Name=Nouvelle base de données
Exec=libreoffice -base %U
TargetEnvironment=Unity

Il est bien sûr possible de supprimer certaines parties de ce script pour les raccourcis que vous n'utiliserez pas.

Après avoir copié ce texte, enregistrez le fichier et redémarrez votre session. Un clic droit sur l'icône de LibreOffice du lanceur affiche maintenant les accès rapides.

Installer des polices

Plus d'information sur la page expliquant comment installer de nouvelles polices de caractère.

Modifier le nom des polices

Quand LibreOffice découvre de nouvelles polices :

  • soit dans le dossier polices du système (/usr/share/fonts/),
  • soit dans le dossier polices de l'utilisateur (~/.fonts),
  • soit dans le dossier "/usr/lib/libreoffice/share/fonts/" des configurations système de LibreOffice,
  • soit dans le dossier "fonts" du répertoire des configurations de LibreOffice de l'utilisateur,

il les ajoute à son cache des polices, nommé "pspfontcache", qui se trouve dans le dossier "psprint" situé dans ce même répertoire des configurations de LibreOffice de l'utilisateur.

En cas de problème ou d'erreur, enlevez les polices erronées du dossier où elles se trouvent, redémarrer LibreOffice, puis les y remettre. Autrement supprimez le fichier "pspfontcache".

Dans ce fichier, il indique le nom du dossier exploré, à chaque changement de dossier ou de sous-dossier :

FontCacheDirectory:1335506239:/usr/share/fonts/truetype/msttcorefonts

Il liste ensuite les fichiers de polices qu'il y trouve, en prenant 4 lignes pour chacun, et séparant deux fichiers de polices par une ligne vide. Par exemple, pour le fichier "/usr/share/fonts/truetype/msttcorefonts/Comic_Sans_MS.ttf", après l'indication du répertoire exploré, il indique :

File:Comic_Sans_MS.ttf
2;1
Comic Sans MS
-1;ComicSansMS;0;5;5;2;65535;1102;291;393;0;1278;1393;1278;1393;0;0;0;0;Regular

La troisième de ces lignes indique le nom que LibreOffice indiquera pour la police dans le menu déroulant : il est donc possible de le modifier avec soin, par exemple pour donner le même nom à toutes les variantes de taille d'une même police…

Macros

Vous pouvez récupérer des macros sur les sites suivants :

Trouver de l'information d'aide à la programmation :

Répertoire par défaut

L'emplacement du répertoire de configuration par défaut est : ~/.config/libreoffice/3/user/ ou ~/.config/libreoffice/4/user/

L'emplacement des scripts python3 de l'utilisateur est : ~/.config/libreoffice/4/user/Scripts/python/

L'emplacement des scripts python3 pour tous les utilisateurs est : /usr/lib/libreoffice/share/Scripts/python/

Utilisation

Lancez l'application souhaitée comme indiqué ici. La suite bureautique LibreOffice étant composée de différents modules, adaptez vos recherches en fonction du nom du module voulu.

Vous pouvez également utiliser les commandes suivantes dans le terminal (toutes versions ou variantes) :

  • LibreOffice Base : traitement de texte
  •  lobase 	Démarre avec une base de données vide. 
  • LibreOffice Calc : tableur
  • localc 	Démarre avec un document Calc vide.
  • LibreOffice Draw application de dessin
  • lodraw 	Démarre avec un document Draw vide.
  • LibreOffice Impress : logiciel de présentation
  • loimpress  	Démarre avec un document Impress vide.
  • LibreOffice Math : création de formules mathématiques
  • lomath 	Démarre avec un document Math vide.
  • LibreOffice Writer : traitement de texte
  •  lowriter 	Démarre avec un document Writer vide. 

Les fichiers de configurations sont dans le dossier ~/.config/libreoffice

Trucs et Astuces

Rendez-vous sur la page consacrée à ce sujet.

Problèmes rencontrés

Désinstallation

Pour supprimer cette application, il suffit de supprimer ses paquets. Selon la méthode choisie, la configuration globale de l'application est conservée ou supprimée. Les journaux du système, et les fichiers de préférence des utilisateurs dans leur dossier personnel sont toujours conservés.

sudo apt-get remove --purge libreoffice*

Alternatives

Voir aussi


Contributeurs principaux : corrigoGeekShadow, , gguillaume017, Wullfk, Julientux , …



Le contenu de ce wiki est sous licence : CC BY-SA v3.0