Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
bauh [Le 17/01/2020, 17:44]
eagle08
bauh [Le 17/09/2020, 23:09] (Version actuelle)
90.46.58.237 typo
Ligne 1: Ligne 1:
-{{tag>​Bionic Application Système ​brouillon}}+{{tag>​Bionic Application Système ​gestionnaire_de_paquets}}
 ---- ----
 {{ https://​cdn.icon-icons.com/​icons2/​54/​PNG/​256/​package_box_10801.png?​100}} {{ https://​cdn.icon-icons.com/​icons2/​54/​PNG/​256/​package_box_10801.png?​100}}
-====== Bauh, le gestionnaire de paquets ​des formats alternatifs Snap, Flatpak, Appimage, Aur ======+====== Bauh (gestionnaire de paquets======
    
-**Bauh** est le Gestionnaire ​de paquets ​des formats alternatifs ​__[[snap|Snap]],​ [[flatpak|Flatpak]],​ [[appimage|Appimage]]__ et enfin __Aur__.+**Bauh** est un [[:​gestionnaire_de_paquets|gestionnaire ​de paquets]] pour les formats ​de distribution ​alternatifs [[:snap|Snap]],​ [[:flatpak|Flatpak]], ​et [[:appimage|Appimage]].
  
-Le développement de l'​application remonte à 2013. Désormais incluse dans la distribution Manjaro par défautelle se nommait à l'​époque ​//fPackman//, probablement en référence au célèbre gestionnaire de paquets AUR nommé — non sans un certain humour — Pacman présent lui au sein de [[wpfr>​Manjaro_Linux|Arch Linux Manjaro]]\\ +Le développement de l'​application remonte à 2013, sous le nom de //fpakman//. Rebaptisée ​**Bauh**, ​et incluse ​dans la distribution Manjaro par défaut, cette application propose maintenant ​une version compatible Debian ​et Ubuntu.
-Peu après avoir été rebaptisée ​**Bauh**, ​elle débarque ​dans une version compatible Debian, dont Ubuntu ​est issue.+
  
-Elle vient compléter graphiquement,​ heureusement et efficacement l'​incapacité de la [[logitheque|Logithèque]] ​et de [[synaptic|Synaptic]] ​à gérer nativement ces nouveaux formats ​de paquets ​précompilés.+En alternative à la [[logitheque|Logithèque]], **Bauh** peut venir compléter graphiquement les [[:​gestionnaire_de_paquets|gestionnaires ​de paquets]] classiques comme [[synaptic|Synaptic]]. On aura alors : 
 +  * Synaptic, chargé ​de gérer les paquets ​natifs ''​.deb''​ 
 +  * et Bauh qui gère les [[:​snap|paquets snap]] issus du [[https://​snapcraft.io/​store|Snapstore]],​ les [[:​flatpak|paquets flatpak]] (généralement installé depuis [[https://​flathub.org/​home|Flathub]]),​ voire même des logiciels au format "​appimage"​ installés depuis [[https://​www.appimagehub.com/​|le AppimageHub]].
  
-Les « App-stores » s'​invitent de plus en plus sous Ubuntu ((Vous vous apercevrez que beaucoup de composants logiciels présents dans l'ISO d'​installation officielle sont — en définitive — [[snap|des paquets snap]] issus du Snapstore)), avec [[https://​snapcraft.io/​store|le Snapstore]],​ [[https://​flathub.org/​home|le Flathub]], [[https://​www.appimagehub.com/​|le Appimage Hub]] et la possibilité de gérer nativement ​[[https://​wiki.archlinux.fr/​AUR_4.0.0|le format Aur]]((site : Dépôt ​des utilisateurs d'Arch Linux)) issu de l'​écosystème [[wpfr>​Arch_Linux|Arch Linux]].+<note tip>​Sur ​[[wpfr>​Arch_Linux|Arch Linux]] et ses dérivées (dont Manjaro par exemple), Bauh gère aussi les paquets issus des [[https://​wiki.archlinux.fr/​AUR_4.0.0|dépôts communautaires AUR]]. La gestion ​des paquets AUR sous Ubuntu à l'aide de Bauh est possible, mais déconseillée.
  
-Bauh est développé en __Python__ et nécessite __les bibliothèques Qt5__. +Afin de gérer les paquets AUR graphiquement sous Bauhvous devez installer ​Pacapt. [[pacapt_pseudo_pacman|La page dédiée à Pacapt]]. Pacapt est en effet un traducteur ​de commandes ​multi-plateformes ​de gestion des paquets.
-  +
-===== Pré-requis ===== +
- Afin de mieux gérer les dépendances de l'​applicationnous allons ​installer ​le paquet [[debfoster|debfoster]],​ présent dans les dépôts. +
-<code bash>​sudo apt-get install debfoster </​code>​ +
-puis +
-  * installer l'​environnement Python. <code bash>​sudo debfoster python3-venv python3-pip </​code>​ +
-  * installer les dépendances de gestion logicielle. +
-    * installer **Flatpak**  +
-      * [[tutoriel:​comment_installer_un_paquet|Comment installer un paquet ?]] **[[apt>​flatpak]]** depuis les dépôts (([[tutoriel:​installer_application_flatpak|Tutoriel : installer une application avec Flatpak]])). +
-      * Le paquet **[[apt>​gnome-software-plugin-flatpak]]** (qui n'​existe pas pour la version 16.04) — optionnel, mais trés formellement conseillé pour plus de confort — permet de gérer les logiciels [[flatpak|Flatpak]] depuis [[logitheque|la logithèque GNOME]]. +
-      * Le paquet **[[apt>​plasma-discover-flatpak-backend]]** (qui n'​existe pas pour la version 16.04) — optionnel, mais trés formellement conseillé pour plus de confort — permet de gérer les logiciels Flatpak depuis [[logitheque|la logithèque KDE]]. +
-      * en une seule commande, via le terminal : \\ <code bash>​sudo debfoster flatpack gnome-software-plugin-flatpak plasma-discover-flatpak</​code>​ +
-    * installer **snapd** (version antérieures à Ubuntu 18.04) <code bash>​sudo debfoster snapd</​code>​ +
-    * installer le transcripteur de commandes **Pacapt** ((<note tip> +
-Bauh est sensé gérer les paquets Arch Linux Manjaro au format AUR. Or : \\ +
-Le gestionnaire de paquets Pacman ne fait pas partie de l'​écosystème Debian Ubuntu. \\ Afin de contourner cette limitation, nous allons installer __le transcripteur ​de commandes ​**Pacapt**__. \\ +
-\\ +
-**(en)** « [[https://​www.ostechnix.com/​use-archlinuxs-pacman-package-manager-unix-like-oss/​|How To Use ArchLinux’s Pacman Package Manager In Other Unix-like OSs]] » — site : OS TechNix.com +
-</​note>​ )) +
-      * sous Ubuntu 18.04 le paquet est présent dans le dépôt universe. <code bash>​sudo debfoster pacapt </​code>​ +
-      * sous Ubuntu 16.04 et suivantes\\ <file bash install Pacact 16-04>​wget -nv https://​download.opensuse.org/​repositories/​home:​Pival81/​xUbuntu_16.04/​Release.key -O Release.key +
-sudo apt-key add - < Release.key +
-sudo sh -c "echo 'deb http://​download.opensuse.org/​repositories/​home:/​Pival81/​xUbuntu_16.04/​ /' > /​etc/​apt/​sources.list.d/​pacapt.list"​ +
-sudo apt-get update +
-sudo apt-get install pacapt </​file>​ +
-<​note>​FIXME le serveur opensuse génère une erreur ​de clé GPGLes diverses tentatives visant à régler ce problème ont échoué. \\ Ceci n'​empèche pas de télécharger Pacapt puis de supprimer son dépôt.</​note>​ +
-    *  +
-      * installer **wget** pour gérer les paquets Appimage et Aur <code bash>​sudo debfoster wget</​code>​ +
-      * installer **Sqlite3** <code bash>​sudo debfoster sqlite3*</​code>​ +
-      * installer **Git** pour gérer les versions AUR <code bash>​sudo debfoster git*</​code>​ +
-      * installer **Aria** pour améliorer le temps de téléchargement des sources Appimage et AUR ; réduit le temps d’installation <code bash>​sudo debfoster aria*</​code>​ +
-      * installer **libappindicator** pour gérer le mode « installation dans la barre de taches » sous Gnome GTK3 <code bash>​sudo debfoster libappindicator* </​code>​ +
-      * installer **Fuse** en cas de dépendance système <code bash>​sudo debfoster fuse* </​code>​ +
-      * installer toutes les dépendances en une seule commande, via le [[terminal|terminal]] <code bash>​sudo debfoster snapd pacact wget* sqlite* git* aria* libappindicator* fuse*</​code>​ +
-  +
-===== Installation de Bauh =====+
  
-Nous allons installer Bauh dans un environnement Python isolé afin de d'​éliminer les problèmes ​d'​interactions système.+Préférez toujours ​un paquet compilé pour votre distribution ​de Linux. Vous vous éviterez des problèmes ​de dépendances.</​note>​
  
-Pour ce faire  +===== Installation ​=====
-  * entrer la commande <code bash>​python3 -m venv bauh_env </​code>​créé l'​environnement Python dans dossier ''​bauh_env''​ situé dans votre dossier personnel, puis  +
-  * installer Bauh <code bash>​bauh_env/​bin/​pip install bauh</​code>​  +
-  +
-===== Création des lanceurs de démarrage et mise à jour automatiques ​=====+
  
-Nous allons créer deux lanceurs, l'un pour le placement du gestionnaire de Bauh dans la barre de taches et l'​autre afin d'​effectuer la mise à jour de Bauh à chaque démarrage du système+==== Pré-requis ====
  
-  * le lanceur ''​Bauh.desktop''​ +Pour installer ​Bauh, il vous faudra :
-<file bash Bauh.desktop>​ +
-[Desktop Entry] +
-Type=Application +
-Name=Bauh.desktop +
-Name[fr_FR]=Bauh.desktop +
-Comment[fr_FR]=Bauh - installe et supprime les applications Snap, FlatpakAppimage & Aur +
-Exec=Exec=bauh --show-panel --download-mthread=1 --max-displayed=100 --check-interval=7200 --locale=fr --tray=1 +
-Icon=/​~/​bauh_env/​lib/​python3.6/​site-packages/​bauh/​view/​resources/​img/​logo_update.png +
-</​file>​+
  
-  * le lanceur ​''​upgrade Bauh.desktop''​ +  ​* une connexion internet fonctionnelle ; 
-<file bash upgrade Bauh.desktop>​ +  * les droits d'​administration de la machine ; 
-[Desktop Entry] +  ​* le gestionnaire de paquet ​''​pip3'' ​dédié au développement d'​application python3 (paquet ​[[apt>​python3-pip]]) ; il permettra ​de télécharger des dépendances spécifiques absentes des dépôts officiels d'​Ubuntu.
-Type=Application +
-Name=Bauh +
-ComName[fr_FR]=upgrade Bauh.desktop +
-Comment[fr_FR]=mise à jour de Bauh +
-Exec=/​~/​bauh_env/​bin/​pip install bauh --upgrade +
-Icon=/​~/​bauh_env/​lib/​python3.6/​site-packages/​bauh/​view/​resources/​img/​logo_update.png +
-GenericName[fr_FR.UTF-8]=mise à jour de Bauh +
-</​file>​+
  
-<note tip>vous pouvez cliquer sur les noms de fichiers pour les télécharger ​et les sauvegarder</​note>​ +Par sa conception, Bauh est modulaire, ​et peut gérer ​les divers formats listés en introductionChacun des formats a évidemment ses propres pré-requis :
-  * placer les lanceurs __dans [[dossiers_et_fichiers_caches|le dossier personnel]] **caché**__ ''/​~/​.config/​autostart''​ +
-===== L'​interface de Bauh =====+
  
 +  * [[apt>​flatpak]] pour les [[:​flatpak|paquets flatpak]] ;
 +  * [[apt>​snapd]] pour les [[:​snap|paquets snap]] ;
 +  * [[apt>​sqlite3]],​ [[apt>​fuse]],​ et [[apt>​wget]] pour le format AppImage ([[apt>​aria2]] est conseillé pour les installations ou mises à jour en parallèle).
  
-{{ https://​raw.githubusercontent.com/​vinifmor/​bauh/​master/​pictures/​panel.png?​1000 ​ }}+==== Procédure d'​installation basique ====
  
-===== Localisation de Bauh =====+[[tutoriel:​comment_installer_un_paquet|Installer les paquets]] suivants :
  
-==== Les fichiers de localisation en français ====+  * [[apt>​python3-pip]] 
 +  * [[apt>​python3-requests]] 
 +  * [[apt>​python3-yaml]] 
 +  * [[apt>​qt5dxcb-plugin]] 
 +  * [[apt>​libappindicator3-1]]
  
-__**Les fichiers de localisation en français**__ ​ — chacun d'​entre-eux est nommé ''​fr''​ — __**n'​existent pas dans les dossiers ''​locale''​**__. Vous pouvez télécharger __**les fichiers de locale**__ ci-dessous.+Puis entrez ​les commandes suivantes :
  
-<note important>FIXME Certaines variables affichées dans les boites de dialogue des applications ne sont pas explicitées dans le fichier locale d'​origine de sorte qu'il est impossible de les traduire et ce quelle que soit la langue. \\ Afin d'​obtenir une traduction complète, il faudrait lister les variables manquantes à partir des sources avant compilation.</note>+<code bash>pip3 install --upgrade pip</code> 
 +<code bash>​pip3 install --upgrade setuptools</​code>​ 
 +<code bash>​pip3 install bauh</​code>
  
-=== Les fichiers de locales ​de la version 32 bits ===+<note tip>Pour plus de détails, une procédure d'​installation avancée est disponible sur la [[https://​github.com/​vinifmor/​bauh|page GitHub du logiciel]] (en anglais).
  
-== Le fichier de locale présent ​dans le dossier lib [...] /bauh/​gems/​appimage [...] ==+Il y est notamment expliqué comment installer Bauh dans un environnement virtuel python (mieux isolé du reste du système)  
 +</note>
  
-<file ascii ~/​bauh_env/​lib/​python3.6/​site-packages/​bauh/​gems/​appimage/​resources/​locale/​fr>​ +=== Erreurs ​à l'​installation ===
-gem.appimage.label=AppImage +
-gem.appimage.info=« aplication publiée sur https://​appimage.github.io/​ » +
-appimage.install.permission=Droits d'​exécution accordés ​à {} +
-appimage.install.extract=Le contenu est en cours d'​extraction à partir de {} +
-appimage.install.desktop_entry=Création d'un raccourci de menu en cours... +
-appimage.uninstall.error.remove_folder=Impossible de supprimer le répertoire d'​installation ​de l'​application {} +
-appimage.info.url_download=adresse Internet du fichier +
-appimage.info.icon_path=icône +
-appimage.history.0_version=version +
-appimage.history.1_published_at=date +
-appimage.history.2_url_download=adresse Internet du fichier +
-appimage.downgrade.impossible.title=Impossible d'​effectuer une rétrogradation de version +
-appimage.downgrade.impossible.body=« Impossible d'​effectuer une rétrogradation de version pour l'​application {} Cette application ne possède actuellement qu'une seule version. » +
-appimage.downgrade.unknown_version.body=« Impossible d'​identifier la version actuelle de l'​application {] dans l'​historique des versions » +
-appimage.downgrade.first_version=Rétrogradation de version impossible pour le paquet Appimage sélectionné. Il s'agit de la toute première version de l'​application {}  +
-appimage.error.uninstall_current_version=Impossible de désinstaller la version actuelle de l'​application {} +
-appimage.downgrade.install_version=Impossible d'​installer la version {} ({}) +
-appimage.install.download.error=Impossible de télécharger le fichier {}. Le serveur qui héberge actuellement le fichier est surement en maintenance. +
-appimage.install.appimagelauncher.error={appimgl} interdit l'​installation de l'​application. Veuillez désinstaller {appimgl}, redémarrer votre ordinateur puis essayer de réinstaller l'​application {app}. +
-</​file>​+
  
-== Le fichier de locale présent dans le dossier lib [...] /​bauh/​gems/​arch [...] ==+Vous pourriez rencontrer cette erreur :
  
-<file ascii ~/​bauh_env/​lib/​python3.6/​site-packages/​bauh/​gems/​arch/​resources/​locale/​fr>​ +<box 95% middle orange |Erreur « No module named 'pip' »> 
-gem.arch.label=AUR +<file bash> 
-gem.arch.info=Les paquets précompilés AUR sont maintenus par une communauté d'​utilisateurs indépendants. Ils sont fournis sans aucune garantie de fonctionnement correct, ni l’assurance qu'ils sont exempts de tout code dommageable à votre système. +bauh_env/​bin/pip install ​bauh --upgrade 
-gem.aur.install.warning=Les paquets précompilés AUR sont maintenus par une communauté d'​utilisateurs indépendants. Ils sont fournis sans aucune garantie de fonctionnement correct, ni l’assurance qu'ils sont exempts de tout code dommageable à votre système. +Traceback (most recent call last): 
-arch.install.conflict.popup.title=Conflit détecté +  File "​bauh_env/​bin/​pip",​ line 6, in <​module>​ 
-arch.install.conflict.popup.body=« Les applications suivantes {} provoquent un conflit. Vous devez déinstaller l'une ou l'​autre. continuer ? +    from pip._internal.cli.main import main 
-arch.missing_deps.title=Dépendances manquantes +ModuleNotFoundError:​ No module named '​pip'​
-arch.missing_deps.body=« Les dépendances suivantes {deps} doivent être installées pour finaliser l'​installation de l'​application {name} » +
-arch.downgrade.error=Erreur +
-arch.downgrade.impossible=« Impossible de procéder à la rétrogradation de version de l'application {} » +
-aur.history.1_version=version +
-aur.history.2_release=publication +
-aur.history.3_date=date +
-arch.downloading.package=Téléchargement du paquet en cours... +
-arch.uncompressing.package=Décompression de l'archive précompilée en cours... +
-arch.checking.deps=Vérification de la disponibilité des dépendances logicielles pour l'​application {} en cours... +
-arch.missing_deps_found=Liste des dépendances logicielles manquantes pour l'​application {} +
-arch.checking.missing_deps=Vérification des dépendances logicielles manquantes pour l'​application {} en cours... +
-arch.building.package=paquet {} en cours de compilation... +
-arch.checking.conflicts=Vérification des conflits éventuels engendrés par l'​application {} en cours... +
-arch.installing.package=Installation du paquet {} en cours... +
-arch.uninstalling.conflict=Désinstallation du paquet conflictuel {} en cours... +
-arch.uninstalling.conflict.fail=Désinstallation du paquet conflictuel {} impossible ! +
-arch.clone=Clônage du dépôt AUR {} en cours... +
-arch.downgrade.reading_commits=Reading the repository commits +
-arch.downgrade.version_found=Current package version found +
-arch.downgrade.install_older=Installing older version +
-aur.info.00_pkg_build=pkgbuild +
-aur.info.01_id=Ident. +
-aur.info.02_name=nom +
-aur.info.03_version=version +
-aur.info.03_description=déscription +
-aur.info.04_popularity=popularité +
-aur.info.05_votes=votes +
-aur.info.06_package_base=base du paquet +
-aur.info.07_maintainer=personne ressource +
-aur.info.08_first_submitted=première mise à disposition +
-aur.info.09_last_modified=dernière modification +
-aur.info.10_url=adresse Internet de téléchargement +
-aur.info.11_pkg_build_url=adresse Internet de l'​archive précompilée « pkgbuild ​» +
-aur.info.13_pkg_build=« pkgbuild » +
-aur.info.12_makedepends=fichiers de dépendances de compilation +
-aur.info.13_dependson=dépendances d'​installation +
-aur.info.14_optdepends=fichiers de dépendances optionnels +
-aur.info.15_checkdepends=vérification des dépendances en cours... +
-aur.info.14_installed_files=Fichiers installés +
-arch.install.dep_not_found.title=Dependency not found +
-arch.install.dep_not_found.body=Required dependency {} was not found in AUR nor in default mirrors. Installation cancelled. +
-arch.install.dependency.install=Installing package dependency {} +
-arch.install.dependency.install.error=Could not install dependent package {}. Installation of {} aborted. +
-arch.uninstall.required_by={} cannot be uninstalled because it is necessary for these following packages to work +
-arch.uninstall.required_by.advice=Uninstall them first before uninstalling {}. +
-arch.install.optdeps.request.title=Optional dependencies +
-arch.install.optdeps.request.body={} was succesfully installed ! There are some optional associated packages that you might want to install +
-arch.install.optdeps.request.help=Check those you want +
-arch.install.optdep.error=Could not install the optional package {} +
-arch.optdeps.checking=Checking {} optional dependencies +
-arch.warning.disabled={} seems not to be installed. It will not be possible to manage Arch AUR packages. +
-arch.warning.git={} seems not to be installed. It will not be possible to downgrade AUR packages. +
-arch.aur.install.verifying_pgp=Verifying PGP keys +
-arch.aur.install.pgp.title=PGP keys required +
-arch.aur.install.pgp.body=To install {} is necessary to receive the following PGP keys +
-arch.aur.install.pgp.substatus=Receiving PGP key {} +
-arch.aur.install.pgp.success=PGP keys received and signed +
-arch.aur.install.pgp.sign_fail=Could not sign PGP key {} +
-arch.aur.install.pgp.receive_fail=Could not receive PGP key {} +
-arch.aur.install.unknown_key.title=Public key required +
-arch.install.aur.unknown_key.body=To continue {} installation is necessary to trust the following public key {} +
-arch.aur.install.unknown_key.status=Receiving public key {} +
-arch.aur.install.unknown_key.receive_error=Could not receive public key {} +
-arch.aur.install.validity_check.title=Integrity issues +
-arch.aur.install.validity_check.body=Some of the source-files needed for {} installation are not healthy. The installation will be cancelled to prevent damage to your system. +
-aur.info.architecture=architecture +
-aur.info.architecture.any=any +
-aur.info.build date=build date +
-aur.info.depends on=depends on +
-aur.info.description=description +
-aur.info.install date=install date +
-aur.info.install reason=install reason +
-aur.info.install reason.explicitly installed=explicitly installed +
-aur.info.install script=install script +
-aur.info.install script.no=no +
-aur.info.installed size=installed size +
-aur.info.licenses=licenses +
-aur.info.name=name +
-aur.info.optional deps=optional deps +
-aur.info.packager=packager +
-aur.info.packager.unknown packager=unknown +
-aur.info.url=url +
-aur.info.version=version +
-aur.info.arch=arch +
-aur.info.arch.any=any +
-aur.info.depends=depends +
-aur.info.pkgdesc=description +
-aur.info.pkgname=name +
-aur.info.pkgrel=release +
-aur.info.pkgver=version +
-aur.info.source=source +
-aur.info.optdepends=optionally depends +
-aur.info.license=license +
-aur.info.validpgpkeys=valid PGP keys +
-aur.info.options=options +
-aur.info.provides=provides +
-aur.info.conflicts with=conflicts with+
 </​file>​ </​file>​
 +</box | Terminal>​
  
-<note tip>Il faudra placer __le fichier ​''​fr''​__ dans le dossier personnel ​''​~/​bauh_env/​lib/​python3.6/​site-packages/​bauh/​gems/​arch/​resources/​locale/​''​ +Cette erreur est due à l'utilisation de ''​pip'' ​à la place de ''​pip3''.
-</​note>​+
  
-== Le fichier de locale présent dans le dossier lib [...] /​bauh/​appimage ​==+===== Création des lanceurs =====
  
-<file gettext fr> +Bauh a été installé via le gestionnaire de paquets ''​pip3''​qui n'est pas le gestionnaire natif de votre système ​l'application n'est pas correctement intégrée ​à Ubuntu, et notamment :
-gem.arch.label=AUR +
-gem.arch.info=Les ​paquets ​précompilés AUR sont maintenus par une communauté d'utilisateurs indépendants. Ils sont fournis sans aucune garantie de fonctionnement correctni l’assurance qu'ils sont exempts ​de tout code dommageable à votre système+
-gem.aur.install.warning=Les paquets précompilés AUR sont maintenus par une communauté d'​utilisateurs indépendants. Ils sont fournis sans aucune garantie de fonctionnement correct, ni l’assurance qu'ils sont exempts de tout code dommageable ​à votre système. +
-arch.install.conflict.popup.title=Conflit détecté +
-arch.install.conflict.popup.body=The applications {} are in conflict. You must uninstall one to install the other. Continue ? +
-arch.missing_deps.title=Missing dependencies +
-arch.missing_deps.body=The following {deps} dependencies must be installed so the {name} installation can continue +
-arch.downgrade.error=Error +
-arch.downgrade.impossible=It is not possible to downgrade {} +
-aur.history.1_version=version +
-aur.history.2_release=release +
-aur.history.3_date=date +
-arch.downloading.package=Downloading the package +
-arch.uncompressing.package=Uncompressing the package +
-arch.checking.deps=Checking {} dependencies +
-arch.missing_deps_found=Missing dependencies for {} +
-arch.checking.missing_deps=Verifying missing dependencies of {} +
-arch.building.package=Building package {} +
-arch.checking.conflicts=Checking any conflicts with {} +
-arch.installing.package=Installing {} package +
-arch.uninstalling.conflict=Uninstalling conflicting package {} +
-arch.uninstalling.conflict.fail=It was not possible to uninstall the conflicting package {} +
-arch.clone=Cloning the AUR repository {} +
-arch.downgrade.reading_commits=Reading the repository commits +
-arch.downgrade.version_found=Current package version found +
-arch.downgrade.install_older=Installing older version +
-aur.info.00_pkg_build=pkgbuild +
-aur.info.01_id=id +
-aur.info.02_name=nom +
-aur.info.03_version=version +
-aur.info.03_description=description +
-aur.info.04_popularity=popularity +
-aur.info.05_votes=votes +
-aur.info.06_package_base=package base +
-aur.info.07_maintainer=maintainer +
-aur.info.08_first_submitted=first submitted +
-aur.info.09_last_modified=last modified +
-aur.info.10_url=url download +
-aur.info.11_pkg_build_url=url pkgbuild +
-aur.info.13_pkg_build=pkgbuild +
-aur.info.12_makedepends=compilation dependencies +
-aur.info.13_dependson=installation dependencies +
-aur.info.14_optdepends=optional dependencies +
-aur.info.15_checkdepends=checking dependencies +
-aur.info.14_installed_files=Installed files +
-arch.install.dep_not_found.title=Dependency not found +
-arch.install.dep_not_found.body=Required dependency {} was not found in AUR nor in default mirrors. Installation cancelled. +
-arch.install.dependency.install=Installing package dependency {} +
-arch.install.dependency.install.error=Could not install dependent package {}. Installation of {} aborted. +
-arch.uninstall.required_by={} cannot be uninstalled because it is necessary for these following packages to work +
-arch.uninstall.required_by.advice=Uninstall them first before uninstalling {}. +
-arch.install.optdeps.request.title=Optional dependencies +
-arch.install.optdeps.request.body={} was succesfully installed ! There are some optional associated packages that you might want to install +
-arch.install.optdeps.request.help=Check those you want +
-arch.install.optdep.error=Could not install the optional package {} +
-arch.optdeps.checking=Checking {} optional dependencies +
-arch.warning.disabled={} seems not to be installed. It will not be possible to manage Arch / AUR packages. +
-arch.warning.git={} seems not to be installed. It will not be possible to downgrade AUR packages. +
-arch.aur.install.verifying_pgp=Verifying PGP keys +
-arch.aur.install.pgp.title=PGP keys required +
-arch.aur.install.pgp.body=To install {} is necessary to receive the following PGP keys +
-arch.aur.install.pgp.substatus=Receiving PGP key {} +
-arch.aur.install.pgp.success=PGP keys received and signed +
-arch.aur.install.pgp.sign_fail=Could not sign PGP key {} +
-arch.aur.install.pgp.receive_fail=Could not receive PGP key {} +
-arch.aur.install.unknown_key.title=Public key required +
-arch.install.aur.unknown_key.body=To continue {} installation is necessary to trust the following public key {} +
-arch.aur.install.unknown_key.status=Receiving public key {} +
-arch.aur.install.unknown_key.receive_error=Could not receive public key {} +
-arch.aur.install.validity_check.title=Integrity issues +
-arch.aur.install.validity_check.body=Some of the source-files needed for {} installation are not healthy. The installation will be cancelled to prevent damage to your system. +
-aur.info.architecture=architecture +
-aur.info.architecture.any=any +
-aur.info.build date=build date +
-aur.info.depends on=depends on +
-aur.info.description=description +
-aur.info.install date=install date +
-aur.info.install reason=install reason +
-aur.info.install reason.explicitly installed=explicitly installed +
-aur.info.install script=install script +
-aur.info.install script.no=no +
-aur.info.installed size=installed size +
-aur.info.licenses=licenses +
-aur.info.name=name +
-aur.info.optional deps=optional deps +
-aur.info.packager=packager +
-aur.info.packager.unknown packager=unknown +
-aur.info.url=url +
-aur.info.version=version +
-aur.info.arch=arch +
-aur.info.arch.any=any +
-aur.info.depends=depends +
-aur.info.pkgdesc=description +
-aur.info.pkgname=name +
-aur.info.pkgrel=release +
-aur.info.pkgver=version +
-aur.info.source=source +
-aur.info.optdepends=optionally depends +
-aur.info.license=license +
-aur.info.validpgpkeys=valid PGP keys +
-aur.info.options=options +
-aur.info.provides=provides +
-aur.info.conflicts with=conflicts with +
-</​file>​+
  
-<note tip>Il faudra placer __le fichier ​''​fr''​__ ​dans le dossier personnel ​''​~/​bauh_env/​lib/​python3.6/​site-packages/​bauh/​gems/​appimage/​resources/​locale''</​note>​+  * elle n'est **pas présente ​dans les menus** 
 +  * elle n'est pas mise à jour par les utilitaires de mise à jour habituels 
 +  * elle ne se lance pas toute seule au démarrage pour vous informer des mises à jour de vos logiciels aux formats Flatpak, Snap, ou AppImage.
  
-== Le fichier de locale présent dans le dossier lib [.../​bauh/​gems/​arch [...] ==+Pour y remédier, on peut créer des [[:​raccourci-lanceur|lanceurs]].
  
-<file ascii fr> +<note tip>Vous pouvez cliquer sur les noms de fichiers pour les télécharger et les sauvegarder.
-gem.arch.label=AUR +
-gem.arch.info=Les paquets précompilés AUR sont maintenus par une communauté d'​utilisateurs indépendants. Ils sont fournis sans aucune garantie ​de fonctionnement correct, ni l’assurance qu'ils sont exempts de tout code dommageable à votre système. +
-gem.aur.install.warning=AUR packages are maintained by an independent user community. There is no warranty that they will work or not harm your system. +
-arch.install.conflict.popup.title=Conflit détecté +
-arch.install.conflict.popup.body=The applications {} are in conflict. You must uninstall one to install the other. Continue ? +
-arch.missing_deps.title=Missing dependencies +
-arch.missing_deps.body=The following {deps} dependencies must be installed so the {name} installation can continue +
-arch.downgrade.error=Error +
-arch.downgrade.impossible=It is not possible to downgrade {} +
-aur.history.1_version=version +
-aur.history.2_release=release +
-aur.history.3_date=date +
-arch.downloading.package=Downloading the package +
-arch.uncompressing.package=Uncompressing the package +
-arch.checking.deps=Checking {} dependencies +
-arch.missing_deps_found=Missing dependencies for {} +
-arch.checking.missing_deps=Verifying missing dependencies of {} +
-arch.building.package=Building package {} +
-arch.checking.conflicts=Checking any conflicts with {} +
-arch.installing.package=Installing {} package +
-arch.uninstalling.conflict=Uninstalling conflicting package {} +
-arch.uninstalling.conflict.fail=It was not possible to uninstall the conflicting package {} +
-arch.clone=Cloning the AUR repository {} +
-arch.downgrade.reading_commits=Reading the repository commits +
-arch.downgrade.version_found=Current package version found +
-arch.downgrade.install_older=Installing older version +
-aur.info.00_pkg_build=pkgbuild +
-aur.info.01_id=id +
-aur.info.02_name=nom +
-aur.info.03_version=version +
-aur.info.03_description=description +
-aur.info.04_popularity=popularity +
-aur.info.05_votes=votes +
-aur.info.06_package_base=package base +
-aur.info.07_maintainer=maintainer +
-aur.info.08_first_submitted=first submitted +
-aur.info.09_last_modified=last modified +
-aur.info.10_url=url download +
-aur.info.11_pkg_build_url=url pkgbuild +
-aur.info.13_pkg_build=pkgbuild +
-aur.info.12_makedepends=compilation dependencies +
-aur.info.13_dependson=installation dependencies +
-aur.info.14_optdepends=optional dependencies +
-aur.info.15_checkdepends=checking dependencies +
-aur.info.14_installed_files=Installed files +
-arch.install.dep_not_found.title=Dependency not found +
-arch.install.dep_not_found.body=Required dependency {} was not found in AUR nor in default mirrors. Installation cancelled. +
-arch.install.dependency.install=Installing package dependency {} +
-arch.install.dependency.install.error=Could not install dependent package {}. Installation of {} aborted. +
-arch.uninstall.required_by={} cannot be uninstalled because it is necessary for these following packages to work +
-arch.uninstall.required_by.advice=Uninstall them first before uninstalling {}. +
-arch.install.optdeps.request.title=Optional dependencies +
-arch.install.optdeps.request.body={} was succesfully installed ! There are some optional associated packages that you might want to install +
-arch.install.optdeps.request.help=Check those you want +
-arch.install.optdep.error=Could not install the optional package {} +
-arch.optdeps.checking=Checking {} optional dependencies +
-arch.warning.disabled={} seems not to be installed. It will not be possible to manage Arch / AUR packages. +
-arch.warning.git={} seems not to be installed. It will not be possible to downgrade AUR packages. +
-arch.aur.install.verifying_pgp=Verifying PGP keys +
-arch.aur.install.pgp.title=PGP keys required +
-arch.aur.install.pgp.body=To install {} is necessary to receive the following PGP keys +
-arch.aur.install.pgp.substatus=Receiving PGP key {} +
-arch.aur.install.pgp.success=PGP keys received and signed +
-arch.aur.install.pgp.sign_fail=Could not sign PGP key {} +
-arch.aur.install.pgp.receive_fail=Could not receive PGP key {} +
-arch.aur.install.unknown_key.title=Public key required +
-arch.install.aur.unknown_key.body=To continue {} installation is necessary to trust the following public key {} +
-arch.aur.install.unknown_key.status=Receiving public key {} +
-arch.aur.install.unknown_key.receive_error=Could not receive public key {} +
-arch.aur.install.validity_check.title=Integrity issues +
-arch.aur.install.validity_check.body=Some of the source-files needed for {} installation are not healthy. The installation will be cancelled to prevent damage to your system. +
-aur.info.architecture=architecture +
-aur.info.architecture.any=any +
-aur.info.build date=build date +
-aur.info.depends on=depends on +
-aur.info.description=description +
-aur.info.install date=install date +
-aur.info.install reason=install reason +
-aur.info.install reason.explicitly installed=explicitly installed +
-aur.info.install script=install script +
-aur.info.install script.no=no +
-aur.info.installed size=installed size +
-aur.info.licenses=licenses +
-aur.info.name=name +
-aur.info.optional deps=optional deps +
-aur.info.packager=packager +
-aur.info.packager.unknown packager=unknown +
-aur.info.url=url +
-aur.info.version=version +
-aur.info.arch=arch +
-aur.info.arch.any=any +
-aur.info.depends=depends +
-aur.info.pkgdesc=déscription +
-aur.info.pkgname=nom +
-aur.info.pkgrel=release +
-aur.info.pkgver=version +
-aur.info.source=source +
-aur.info.optdepends=dépendances optionnelles +
-aur.info.license=license +
-aur.info.validpgpkeys=clés PGP valides +
-aur.info.options=options +
-aur.info.provides=Fournit +
-aur.info.conflicts with=conflicts with +
-</​file>​+
  
-<note tip>Il faudra placer __le fichier ''​fr''​__ dans le dossier ​personnel ​''​~/​bauh_env/​lib/​python3.6/site-packages/​bauh/​gems/​arch/​resources/locale''</​note>​+Si le dossier ​caché ​''​~/​.config/autostart/'' ​n'​existe pas, créez-le préalablement.</​note>​
  
-== Le fichier de locale présent dans le dossier flatpak ​==+==== Ajouter Bauh à la liste des applications ====
  
-<​file ​ascii fr+<​file ​desktop Bauh.desktop
-gem.flatpak.info=Applications disponibles dans les dépôts définis dans votre système +[Desktop Entry] 
-flatpak.notification.no_remotes=Aucun dépôt FlatHub n'est défini. Impossible d'​effectuer une recherche de paquets au format Flatpak. +Type=Application 
-flatpak.notification.disable=Si vous ne souhaitez pas utiliser le format Flatpak, décochez {} dans {} +Name=Bauh.desktop 
-flatpak.downgrade.impossible.title=Erreur +Name[fr_FR]=Bauh.desktop 
-flatpak.downgrade.impossible.body=Impossible d'​effectuer une rétrogradation de version : il s'agit de la version initiale de l'​application +Comment[fr_FR]=Bauh - installe et supprime les applications Snap, Flatpak & Appimage 
-flatpak.downgrade.commits=Reading package commits +Exec=bauh
-flatpak.downgrade.reverting=Reverting version +
-flatpak.info.flatpakappid=id +
-flatpak.info.bugtrackerurl=bug tracker URL +
-flatpak.info.currentreleasedate=release date +
-flatpak.info.currentreleasedescription=version description +
-flatpak.info.currentreleaseversion=version +
-flatpak.info.donationurl=donation URL +
-flatpak.info.downloadflatpakrefurl=Ref +
-flatpak.info.helpurl=Help url +
-flatpak.info.homepageurl=Home url +
-flatpak.info.instoresincedate=added in +
-flatpak.info.projectlicense=license +
-flatpak.info.translateurl=translate url +
-flatpak.info.developername=developer +
-flatpak.info.arch=arch +
-flatpak.info.branch=branch +
-flatpak.info.collection=collection +
-flatpak.info.commit=commit +
-flatpak.info.date=date +
-flatpak.info.description=description +
-flatpak.info.id=id +
-flatpak.info.installation=installation +
-flatpak.info.installed=installed +
-flatpak.info.license=license +
-flatpak.info.name=name +
-flatpak.info.origin=origin +
-flatpak.info.parent=parent +
-flatpak.info.ref=ref +
-flatpak.info.runtime=runtime +
-flatpak.info.sdk=sdk +
-flatpak.info.subject=subject +
-flatpak.info.type=type +
-flatpak.info.version=version +
-flatpak.history.date=date +
-flatpak.history.commit=commit+
 </​file>​ </​file>​
  
-<note tip>Il faudra placer __le fichier ''​fr''​__ ​dans le dossier ​personnel ​''​~/​bauh_env/​lib/​python3.6/site-packages/bauh/gems/​flatpak/​resources/​locale''​</​note>​+Placez ce lanceur ​dans [[dossiers_et_fichiers_caches|le dossier ​caché]] ​''​~/​.local/share/applications/''​
  
-=== Les fichiers de locale de la version 64 bits ===+==== Lancer Bauh en arrière-plan ====
  
-== Le fichier ​de locale présent dans le dossier lib64 [...] appimage ==+Pour vous informer des mises à jour de vos logiciels aux formats Flatpak, Snap, ou AppImage.
  
-<​file ​ascii fr+<​file ​desktop Bauh.desktop
-gem.appimage.label=AppImage +[Desktop Entry] 
-gem.appimage.info=aplication publiée sur https://​appimage.github.io/​ +Type=Application 
-appimage.install.permission=Droits d'​exécution accordés à {} +Name=Bauh.desktop 
-appimage.install.extract=Le contenu est en cours d'​extraction à partir de {} +Name[fr_FR]=Bauh.desktop 
-appimage.install.desktop_entry=Création d'un raccourci de menu en cours..+Comment[fr_FR]=Bauh - installe et supprime les applications Snap, Flatpak & Appimage 
-appimage.uninstall.error.remove_folder=Impossible de supprimer le répertoire d'​installation de l'​application {} +Exec=bauh --tray
-appimage.info.url_download=adresse Internet du fichier +
-appimage.info.icon_path=icône +
-appimage.history.0_version=version +
-appimage.history.1_published_at=date +
-appimage.history.2_url_download=adresse Internet du fichier +
-appimage.downgrade.impossible.title=Impossible d'​effectuer une rétrogradation de version +
-appimage.downgrade.impossible.body={} Cette application ne possède actuellement qu'une seule version. +
-appimage.downgrade.unknown_version.body=Impossible d'​identifier la version actuelle de l'​application {dans l'​historique des versions +
-appimage.downgrade.first_version=Il s'agit de la toute première version de l'​application {}  +
-appimage.error.uninstall_current_version=Impossible de désinstaller la version actuelle de l'​application {} +
-appimage.downgrade.install_version=Impossible d'​installer la version {} ({}) +
-appimage.install.download.error=Impossible de télécharger le fichier {}. Le serveur hébergeant le fichier est surement en maintenance. +
-appimage.install.appimagelauncher.error={appimgl} interdit l'​installation de l'​application. Veuillez désinstaller {appimgl} puis redémarrer votre ordinateur ; enfin, essayer de réinstaller l'​application {app}.+
 </​file>​ </​file>​
  
-<note tip>Il faudra placer __le fichier ''​fr''​__ ​dans le dossier ​personnel ​''​~/​bauh_env/​lib64/​python3.6/site-packages/bauh/​gems/​appimage/​resources/​locale''​</​note>​+Placez ce lanceur ​dans [[dossiers_et_fichiers_caches|le dossier ​caché]] ​''​~/​.config/autostart/''​
  
 +==== Mise à jour automatique en arrière-plan ====
  
-  * **redémarrer votre ordinateur**+Le lanceur ''​MAJ-Bauh.desktop''​ a pour but d'​automatiser la mise à jour de l'​application Bauh.
  
-===== Fonctionnement de Bauh =====+<file desktop MAJ-Bauh.desktop>​ 
 +[Desktop Entry] 
 +Type=Application 
 +Name=Mettre à jour Bauh 
 +Exec=pip3 install bauh --upgrade 
 +</​file>​
  
-==== Ses différentes fonctionnalités ====+Placez ce lanceur dans [[dossiers_et_fichiers_caches|le dossier caché]] ''​~/​.config/​autostart/''​
  
-  * {{https://​cdn.icon-icons.com/​icons2/​54/​PNG/​256/​package_box_10801.png?​30}} **Gems** (gestion des paquets) +<​note>​Au mois de mai 2020le développement ​de Bauh est soutenu ​et assez fréquentAu démarrage, de Bauhles alertes ​de mises à jour s'afficheront ​à l'écran. lancer la mise à jour, si celle-ci n'a pas été faite.</​note>​
-  * {{https://​upload.wikimedia.org/​wikipedia/​commons/​1/​1a/​Flatpak_logo.png?​30}} ​ **Flatpak** (le format flatpak) L'​utilisateur a la possibilité d'​effectuer une recherche, d'​installer, ​de désinstallerd'​effectuer une rétrogradation ​de version, de lancer une application ​et enfin d'​avoir accès à l'​historique de l'​application +
-  * {{https://​cdn4.iconfinder.com/​data/​icons/​logos-brands-5/​24/​snapcraft-512.png?​30}} **Snap** (le format snap) L'​utilisateur a la possibilité d'​effectuer une recherche, d'​installer, de désinstallerd'​effectuer une rétrogradation ​de version, de lancer une application et enfin d'avoir accès ​à l'historique de l'​application +
-  * {{https://​upload.wikimedia.org/​wikipedia/​commons/​thumb/​7/​73/​App-image-logo.svg/​220px-App-image-logo.svg.png?​30}} **AppImage** L'​utilisateur a la possibilité d'​effectuer une recherche, d'​installer,​ de désinstaller,​ d'​effectuer une rétrogradation de version, de lancer ​une application et enfin d'​avoir accès à l'​historique de l'​application +
-    * Site pris en charge pour la gestion des sources: [[https://​appimage.github.io/​apps/​|AppImageHub]] \\ l'​application Bauh ne prend actuellement pas en charge les sources d'​applications hors du dépôt GitHub((Il s'agit du dépôt Appimage GitHub.)) +
-    * La rapidité de téléchargement est améliorée si vous avez installé **aria2c**. Same behavior described in the AUR support section. +
-    * Les applications installées sont stockées dans le dossier ''​~/​.local/​share/​bauh/​appimage/​installed''​ +
-    * Les raccourcis de menu pour le gestionnaire de bureau sont stockés [[fichier_cache|dans le dossier caché]] ''​~/​.local/​share/​applications''​ +
-    * Les fichiers de bases de données téléchargés sont stockés dans le dossier ''​~/​.local/​share/​bauh/​appimage''​ et se nomment ''​apps.db''​ et ''​releases.db''​ +
-    * Le service de mise à des bases de données intervient toutes les  20 minutes. \\ L'​intervalle en SECONDES peut être modifié grâce à la variable d'​environnement **BAUH_APPIMAGE_DB_UPDATER_TIME**. \\ Le service de mises à jour automatisées peut être désactivé à l'aide de la variable d'​environnement **BAUH_APPIMAGE_DB_UPDATER=0**.+
  
-<note tip>​**NB** : Une liste exaustive des applications supportées se trouve à l'​adresse [[https://​github.com/​vinifmor/​bauh-files/​blob/​master/​appimage/​apps.txt|Liste des applications Appimage sur le Github]]</​note>​+===== Utilisation =====
  
-<note important>​**ATTENTION** : There are some crashes when AppImageLauncher is installed. It is advisable to uninstall it and reboot the system before trying to install an AppImage application. +==== Interface ====
-AUR ( arch )</​note>​+
  
-The user is able to search, install, uninstall, downgrade, launch and retrieve the packages history. +{{ https://raw.githubusercontent.com/vinifmor/​bauh/​master/​pictures/​panel.png?​900 ​ }}
-It handles conflicts, and missing ​optional packages installations ( including from your distro mirrors )+
  
-<note tip>Si  +==== Formats ​de paquets ("​Gems"​) supportés ====
-  - **aria2** est installé sur votre système — nous nous en sommes assurés à l'​étape de l'​installation des dépendances logicielles —  +
-  - ajouté à cela que les téléchargements multicanaux sont activés ; **BAUH_DOWNLOAD_MULTITHREAD=1** +
-dans ce cas, les fichiers-sources seront téléchargés plus rapidement. Ceci n'​affecte en rien les paramètres ​de Pacman. ​+
  
-**NB** ​Vérifier l'​état de la variable **BAUH_DOWNLOAD_MULTITHREAD**,​ au besoin, vous pouvez l'​activer en la plaçant dans le raccourci de chargement de Bauh dans la barre de lancement rapideRaccourci crée à l'​étape précédente +{{  https://upload.wikimedia.org/wikipedia/​commons/​1/​1a/​Flatpak_logo.png?​40}}
-</note>+
  
-<note important>​Unelmiste exhaustive des variables d’environnement est disponible dans cette documentation au chapitre [[bauh#​parametrage_a_l_aide_des_variables_d_environnement|Bauh : Chapitre 6 - Paramétrage à l'aide des variables d'​environnement]]</​note>​+=== Flatpak ===
  
-Automatically makes simple package compilation improvements : +Pour les applications au format flatpakl'​utilisateur ​la possibilité d'​effectuer une recherched'installer, de désinstaller,​ d'effectuer une rétrogradation de version, de lancer une application,​ et d'​avoir accès à l'​historique de l'​application.
-  * if MAKEFLAGS is not set in /​etc/​makepkg.confthen copy of /​etc/​makepkg.conf will be generated at ~/​.config/​bauh/​arch/​makepkg.conf defining MAKEFLAGS to work with the number of your machine processors (-j${nproc}). +
-  * same as previousbut related to COMPRESSXZ definition ( if '--threads=0' ​is not defined )+
  
-<note tip>​NB ​this feature can be disabled through the environment variable BAUH_ARCH_OPTIMIZE=0 ( For more information about these optimizations,​ have a look at Makepkg ) +{{  https://​cdn4.iconfinder.com/​data/​icons/​logos-brands-5/​24/​snapcraft-512.png?​40}}
-</note>+
  
-Arch package memory-indexer running every 20 minutes. This memory index is used when AUR Api cannot handle the amount of results found for a given search. It can be disabled via the environment variable BAUH_ARCH_AUR_INDEX_UPDATER=0.+=== Snap ===
  
-If some of your installed packages are not categorized,​ send an e-mail to bauh4linux@gmail.com informing their names and categories in the following ​format: name=category1[,category2,category3,...]+Pour les applications au format ​snapl'​utilisateur a la possibilité d'​effectuer une recherched'​installerde désinstaller,​ d'​effectuer une rétrogradation de version, de lancer une application,​ et d'​avoir accès à l'​historique de l'​application.
  
-Transitive dependencies checking can be disabled through the environment variable BAUH_ARCH_CHECK_SUBDEPS=0The dependency checking process will be faster, but the application will ask for a confirmation every time a not installed dependency is detected.+{{  https://​upload.wikimedia.org/​wikipedia/​commons/​thumb/​7/​73/​App-image-logo.svg/​220px-App-image-logo.svg.png?​40}}
  
-==== Paramètres généraux ==== +=== AppImage ​===
  
-=== Paramétrage ​à l'aide des variables ​d'environnement ===+L'​utilisateur a la possibilité d'​effectuer une recherche, d'​installer,​ de désinstaller,​ d'​effectuer une rétrogradation de version, de lancer une application et enfin d'​avoir accès ​à l'historique de l'​application 
 +  * Site utilisé comme source : [[https://​appimage.github.io/​apps/​|AppImageHub]]. L'​application Bauh ne prend pas en charge les sources ​d'applications hors de ce dépôt GitHub. 
 +  * Les applications installées au format appimage sont stockées dans le dossier ''​~/​.local/​share/​bauh/​appimage/​installed''​ 
 +  * Les raccourcis de menu pour le gestionnaire de bureau sont stockés [[fichier_cache|dans le dossier caché]] ''​~/​.local/​share/​applications''​ 
 +  * Les fichiers de bases de données téléchargés sont stockés dans le dossier ''​~/​.local/​share/​bauh/​appimage''​ et se nomment ''​apps.db''​ et ''​releases.db''​
  
-Vous avez la possibilité de modifier certains ​des paramètres ​de l'​application grâce aux différentes variables d'​environnement et aux arguments qui y sont associés. \\ Entrer dans un [[terminal|terminal]+<note tip>Une liste exhaustive ​des applications supportées se trouve à [[https://​github.com/​vinifmor/​bauh-files/​blob/​master/​appimage/​apps.txt|Le GitHub du développeur]]. \\  
-<code bash>​bauh --help ​</code>+__Il est tout à fait possible ​de gérer des fichiers au format Appimage téléchargés par vos soins sur la toile__. \\ 
 +  * Cliquer sur le signe [+en bas de l'​écran des applications gérées par Bauh, puis  
 +  * compléter les informations dans les champs de description des applications 
 +</note>
  
-Vous obtenez la liste des variables d'​environnement de l'application ​Bauh.+<note important>​__**AppImageLauncher** est totalement incompatible avec BAUH__. Si vous l'avez installé sur votre système, il vous faudra choisir le logiciel de gestion du format Appimage. \\ Si vous souhaitez utiliser ​Bauh, il vous faudra absolument désinstaller AppimageLauncher grace à la commande :  
 +<code bash>​sudo find / -type f -name "​[Aa]pp[Ii]mage[Ll]auncher"​ -exec rm -f '​{}'​ \;</​code>​ 
 +Cette commande cherche toutes les instances de noms de fichier entre guillemets et ce quelle que soit la casse utilisée pour la graphie des noms de fichiers.
  
-<note important>​Il est important de respecter l'​ordre de de saisie des variables dans le Terminal ou dans une commande de raccourci. Dans le le cas contraire, certaines variables peuvent ne pas être exécutées. \\  +</​note>​
-C'est notamment le cas de --locale=fr ou --tray</​note>​+
  
-L'​argument --help ​de Bauh renvoie+==== Options en lignes ​de commandes ====
  
-<box 75% middle orange |Commande : bauh --help+Tapez <code bash>bauh --help </codepour afficher les options possibles. Le contenu de cette aide ne sera pas recopié ni détaillé ici, car il change au fil des mises à jour de l'​​application.
-<file> +
-usage: bauh [-h] [-v] [-e CACHE_EXP] [-ie ICON_EXP] [-LOCALE] +
-            [-i CHECK_INTERVAL] [-n {0,1}] [-dc {0,1}] [-di {0,1}] [-co {0,1}] +
-            [--tray {0,1}] [--sugs {0,1}] [-md MAX_DISPLAYED] [--logs {0,1}] +
-            [--show-panel] [-dmt {0,1}] [--clean]+
  
-GUI for Linux package management +<note tip>​Quand vous utilisez de telles options, gardez à l'​esprit que leur **ordre d'​​écriture** dans la commande est essentiel !</note>
-</file> +
-</box | Terminal>+
  
-  * **BAUH_SYSTEM_NOTIFICATIONS**:​ active ou désactive les notifications système. \\ Paramètre ​ ''​0''​ (inactif) or ''​1''​ (actif, default). schéma de l'​argument <code bash>-n {0,1} </​code>​ \\ utilisation de l'​argument<​code bash>​bauh -n=1 </​code>​ +===== Paramétrage =====
-  * **BAUH_CHECK_INTERVAL**:​ définit les intervalles en secondes des vérifications de mises à jour \\ Défaut: ''​60''​. schéma de l'​argument <code bash>-i {nn} </​code>​ \\ utilisation de l'​argument<​code bash>​bauh --check-interval=60  </​code>​ +
-  * **BAUH_LOCALE** : define a custom app translation for a given locale key (e.g: ''​pt'',​ ''​en'',​ ''​es'',​ ...). \\ Défaut : ''​system locale''​. schéma de l'​argument <code bash>-l {xx} </​code>​ \\ utilisation de l'​argument<​code bash>​bauh --locale=fr </​code>​ +
-  * **BAUH_CACHE_EXPIRATION** : define a custom expiration time in SECONDS for cached API data. \\ Défaut: ''​3600''​ (1 hour). schéma de l'​argument <code bash>-e {nn} </​code>​ \\ utilisation de l'​argument<​code bash>​bauh --cache-exp=3600 </​code>​ +
-  * **BAUH_ICON_EXPIRATION** : define a custom expiration time in SECONDS for cached icons. \\ Default: ''​300''​ (5 minutes). +
-  * **BAUH_DISK_CACHE** : enables / disables disk cache. When disk cache is enabled, the installed packages data are loaded faster. \\ Use ''​0''​ (inactif) or ''​1''​ (actif, défaut). schéma de l'​argument <code bash>-dc {0,1} </​code>​ \\ utilisation de l'​argument<​code bash>​bauh --disk-cache=1 </​code>​ +
-  * **BAUH_DOWNLOAD_ICONS** : Enables / disables applications icons downloading. ​ \\ It may improve the application speed depending on how applications data are being retrieved. Use 0 (inactif) or 1 (actif, défaut). +
-  * **BAUH_CHECK_PACKAGING_ONCE** : If the availabilty of the supported packaging types should be checked only once. \\ It improves the application speed if enabled, but can generate errors if you uninstall any packaging technology while using it, and every time a new supported packaging type is installed it will only be available after a restart. Use ''​0''​ (disable, default) or ''​1''​ (enable). +
-  * **BAUH_TRAY**:​ If the tray icon and update-check daemon should be created. Use ''​0''​ (disable, default) or ''​1''​ (enable). +
-  * **BAUH_SUGGESTIONS**:​ If application suggestions should be displayed if no package considered an application is installed (runtimes / libraries do not count as applications). Use ''​0''​ (disable) or ''​1''​ (enable, default). +
-  * **BAUH_MAX_DISPLAYED**:​ Maximum number of displayed packages in the management panel table. Default: ''​50''​. +
-  * **BAUH_LOGS**:​ enable bauh logs (for debugging purposes). Use: ''​0''​ (disable, default) or ''​1''​ (enable) +
-  * **BAUH_DOWNLOAD_MULTITHREAD** : enable multi-threaded download for installation files (only possible if aria2 is installed ). This feature reduces the application installation time. Use ''​0''​ (disable) or ''​1''​ (enabled, default). +
-  * **BAUH_TRAY_DEFAULT_ICON_PATH** : define a custom icon for the tray mode ( absolute path) +
-  * **BAUH_TRAY_UPDATES_ICON_PATH** : define a custom updates icon for the tray mode (absolute path)+
  
-=== How to improve bauh performance ===+Le bouton "​​engrenage"​​,​ visible en bas de la fenêtre, vous permet d'​​accéder facilement aux paramètres les plus courants. Les labels dans l'​​interface sont clairs et peuvent se passer d'​​explications détaillées.
  
-Disable package types that you do not want to deal with ( via GUI ) +Les changements de paramètres prennent effet au redémarrage de l'​application.
-If you don't care about restarting the app every time a new supported packaging technology is installed, set "​check-packaging-once=1"​ (bauh --check-packaging-once=1). This can reduce the application ​response time up in some scenarios, since it won't need to recheck if the packaging type is available for every action you request. +
-If you don't mind to see the applications icons, you can set "​download-icons=0"​ (bauh --download-icons=0). The application may have a slight response improvement,​ since it will reduce the parallelism within it. +
-Let the disk cache always enabled so bauh does not need to dynamically retrieve some data every time you launch it.+
  
-=== Files and Logs ===+==== Fichiers et journaux ====
  
-Some application settings are stored in ~/​.config/​bauh/​config.json +À titre indicatif :
-Installation logs are saved at /​tmp/​bauh/​logs/​install +
-Some data about your installed applications are stored in ~/​.cache/​bauh to load them faster ( default behavior ).+
  
-==== Structure du code  ====+  * La configuration de l'​application peut se trouver dans ''​~/​​.config/​​bauh/​​config.json''​ 
 +  * Les journaux d'​installation sont présents à ce chemin ''/​​tmp/​​bauh/​​logs/​​install''​ (attention ce sont des fichiers temporaires) 
 +  * Des données sur les applications sont présentes dans ''​~/​​.cache/​​bauh''​ (pour un fonctionnement plus rapide de l'​application)
  
-=== Modules ​===+==== Localisation en français ====
  
-  * **view**: code chargé ​de gérer ​l'interface graphique +Vous pouvez essayer ​de localiser ​l'application ​en français ​:
-  * **gems**: code chargé d'​interagir avec chaque type de paquet précompilé (chaque sous module peut prendre ​en charge un seul, voire plusieurs types de paquets) +
-  * **api**: abstractions du code représentant les actions principales qu'un utilisateur s'​attend à accomplir sur les diférents paquets Linux (recherche, installation,​ etc…). Ces abstractions sont mises en oeuvre grace aux modules gems ; le module view ne servant qu'à compléter leur champs d'​action spécifique (view n'a aucune incidence directe sur les actions des modules gems) +
-  * **commons**code commun partagé par les modules **gems** et **view**+
  
 +  - intégrer les fichiers de locales en français, disponibles à la page [[:​utilisateurs/​eagle08/​bac_a_sable|Bac à sable de eagle08]] (auteur de la traduction et contributeur de la présente page)
 +
 +<note tip>Les locales en français n'​existent pas ; ni la possibilité de paramétrer le Français dans les paramètres. \\
 +Une façon saine et sans risque de localiser Bauh en Français consiste à remplacer le contenu d'une langue inutilisée par son contenu traduit en Français. \\
 +Par exemple, choisir Catalan dans les Paramètres
 +copier-coller le contenu en Français dans le fichier de locale correspondant en Catalan, nommés ''​ca''​ dans les dossiers de locales. \\
 +Cette manipulation sans risque à l'​avantage de ne pas toucher aux paramètres de fonctionnement de Bauh. Nous nous contentons de changer la langue.</​note>​
 +Pour appliquer la traduction, **redémarrez votre ordinateur**.
  
 ===== Désinstallation ===== ===== Désinstallation =====
    
-Pour supprimer cette application,​ il suffit de [[:tutoriel:comment_supprimer_un_paquet|supprimer son paquet]]. Selon la méthode choisie, la configuration globale ​de l'​application ​est conservée ou suppriméeLes journaux du système, et les fichiers de préférence des utilisateurs dans leurs dossiers personnels sont toujours conservés.+Lancer dans un terminal la commande suivante ​: 
 +<code bash> 
 +bauh --reset 
 +sudo find / -type f -name "[Bb]auh" -exec rm -f '​{}'​ \; 
 +</​code>​ 
 +Cette commande supprimera le dossier ''/​bauh_env'' ​de votre dossier personnel et par là-même désinstallera ​l'​application. ​\\ 
 +Puis effacera tous les fichiers de configuration de Bauh. 
 + 
 +===== Documentation =====
    
-===== Voir aussi ===== +  ​* **(en)** [[https://​github.com/​vinifmor/​bauh|Dépôt github ​officiel du logiciel]]
-  +
-  ​* **(en)** [[https://​github.com/​vinifmor/​bauh|Site officiel du logiciel]]+
   * **(en)** [[https://​forum.manjaro.org/​t/​bauh-formerly-known-as-fpakman-a-gui-for-flatpak-and-snap-management/​96180/​33|Blog officiel de l'​auteur du logiciel Bauh]] — site : Forum sur Manjaro.org ; Auteur : vfm90.   * **(en)** [[https://​forum.manjaro.org/​t/​bauh-formerly-known-as-fpakman-a-gui-for-flatpak-and-snap-management/​96180/​33|Blog officiel de l'​auteur du logiciel Bauh]] — site : Forum sur Manjaro.org ; Auteur : vfm90.
   * **(fr)** [[https://​infoidevice.fr/​bauh-gerer-paquets-snap-flatpak-appimage|« Bauh : gérer les paquets Snap, Flatpak et AppImage avec une seule interface »]] — site : Info Idevice.fr.   * **(fr)** [[https://​infoidevice.fr/​bauh-gerer-paquets-snap-flatpak-appimage|« Bauh : gérer les paquets Snap, Flatpak et AppImage avec une seule interface »]] — site : Info Idevice.fr.
   * **(en)** « [[https://​www.ostechnix.com/​use-archlinuxs-pacman-package-manager-unix-like-oss/​|How To Use ArchLinux’s Pacman Package Manager In Other Unix-like OSs]] » — site : OS TechNix.com   * **(en)** « [[https://​www.ostechnix.com/​use-archlinuxs-pacman-package-manager-unix-like-oss/​|How To Use ArchLinux’s Pacman Package Manager In Other Unix-like OSs]] » — site : OS TechNix.com
    
----- +-----
-  +
-//​Contributeurs principaux : [[utilisateurs:​eagle08|René Stoecklin]].//​+
    
 +//​Contributeurs principaux :
 +[[:​utilisateurs:​eagle08|René Stoecklin]],​
 +[[:​utilisateurs:​roschan|roschan]],​
 +...//
 +
  • bauh.1579279487.txt.gz
  • Dernière modification: Le 17/01/2020, 17:44
  • par eagle08