Utiliser Linux pour se connecter au Réseau Privé Virtuel des Avocats

Les avocats exerçant devant les juridictions dont la procédure relève de la procédure écrite sont dans l'obligation de transmettre certains actes de procédure par voie électronique aux juridictions.

Ce transfert se fait par connexion internet via un navigateur web, vers un serveur sécurisé en charge de la gestion des échanges entre les avocats et les juridictions.

Le système nécessitait deux dispositifs de sécurité : un boitier NAVISTA faisant office de VPN et une clef de certification fournies par l'ordre des avocats utilisé par le navigateur internet pour le chiffrage et la sécurisation de la connexion au serveur.

Me CUIFF a fait un descriptif assez complet de l'architecture du dispositif

Le boitier NAVISTA n'est plus nécessaire depuis le mois d'avril 2016. Désormais la connexion au RPVA ne nécessite que l'installation d'une clef de sécurité permettant l'identification de l'utilisateur.

Cette clef est commandée auprès du CNB - organisme national fédérant les différentes organisations locales des avocats (les barreaux).

L'avocat va récupérer auprès de son ordre local, une clef USB et des instructions d'installation et d'activation pour Windows et MacOs.

Sur Linux, la clef de certification nécessite d'être reconnue par le navigateur web. À ce jour, cette solution n'a été testée qu'avec Firefox.

Ce tutoriel décrit une méthode permettant de le faire selon que vous disposiez d'un ancien modèle de clef (avant 2016 / Modèle ???) ou d'un nouveau modèle (après 2016 / GEMALTO ID PRIME MD 840).

MISE A JOUR : Le tutoriel pour les nouvelles clefs grâce au travail magnifique de [https://aw-avocats.fr/| Me Romain WINCZEWSKI] * Testé sur UBUNTU 19.10 et 16.04

Reconnaissance matérielle de la clef

La clé est une IDGO 800 qui nécessite de nouveaux drivers.

Pré-requis

Installer les dépendances :

$ sudo apt install pcscd pcsc-tools

Vérifier que le service pcsc est actif :

$ systemctl status pcscd

Résultat (vérifier la présence de la mention active / running) :

 pcscd.service - PC/SC Smart Card Daemon
   Loaded: loaded (/usr/lib/systemd/system/pcscd.service; indirect; vendor preset: disabled)
   Active: active (running) since Mon 2019-05-27 22:22:27 -03; 1h 23min ago
     Docs: man:pcscd(8)
 Main PID: 25347 (pcscd)
    Tasks: 8 (limit: 4915)
   CGroup: /system.slice/pcscd.service
           └─25347 /usr/sbin/pcscd –foreground

Insérer la clé RPVA et vérifier que le résultat de la commande lsusb comprend bien la ligne Gemalto GemPC Key SmartCard Reader (seconde ligne dans l'exemple de résultat ci-dessous) :

$ lsusb

Résultat :

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 005: ID 08e6:3438 Gemalto (was Gemplus) GemPC Key SmartCard Reader 
Bus 002 Device 004: ID 0e0f:0008 VMware, Inc. VMware Virtual USB Mouse
Bus 002 Device 003: ID 0e0f:0002 VMware, Inc. Virtual USB Hub
Bus 002 Device 002: ID 0e0f:0003 VMware, Inc. Virtual Mouse 
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Vérifier la reconnaissance de la clé par pcsc (on doit trouver la mention Gemalto USB Shell Token V2 dans le résultat) :

$ pcsc_scan

Résultat :

Using reader plug'n play mechanism
Scanning present readers...
0: Gemalto USB Shell Token V2 (B21C5FA8) 00 00
Thu Jan 30 17:50:27 2020
 Reader 0: Gemalto USB Shell Token V2 (B21C5FA8) 00 00
  Event number: 0
  Card state: Card inserted, Shared Mode, 
  ATR: 3B 7F 96 00 00 80 31 80 65 B0 85 03 00 EF 12 0F FE 82 90 00

Téléchargement du driver le plus récent en .npm

La version la plus récente que j’ai pu trouver est un driver Gemalto dénommé SafeNetAutenticationClient, en version 10.7.77.

On ne le trouve qu’en paquet npm pour Fedora à l’adresse suivante :

https://www.certinomis.com/publi/drivers/SafenetAuthenticationClient-10.7.77-1.x86_64.rpm

Il faut donc le convertir en .deb.

– Conversion en .deb

Installer le package alien et certaines dépendances :

$ sudo apt install alien dpkg-dev debhelper build-essential

Convertir le paquet :

$ sudo alien SafenetAuthenticationClient-10.7.77-1.x86_64.rpm

Installer le paquet .deb après conversion :

$ dpkg -i SafenetAuthenticationClient-10.7.77-1.x86_64.deb

Installation du module de sécurité et des certificats sous Firefox

Allez dans Vie privée et sécurité/Sécurité (côté droit, en bas de la page)/Certificats puis cliquez sur Afficher les certificats.

Dans l’onglet Autorités, cliquez sur Importer.

Importer tour à tour les quatre certificats en validant à chaque fois (touche Ok).

Liens de téléchargement des certificats :

http://www.certeurope.fr/reference/certeurope_root_ca_3.cer

https://www.certeurope.fr/reference/CertEurope_eID_Root.cer

http://www.certeurope.fr/reference/certeurope_advanced_v4.cer

https://www.certeurope.fr/reference/CertEurope_eID_User.cer

La clé toujours insérée, allez dans le menu Outils/Options du menu Firefox puis dans Vie privée/Sécurité (côté droit, en bas de page), puis cliquez sur Périphériques de sécurité. Dans l’onglet Certificats, cliquez sur Périphériques de Sécurité.

Cliquez sur Charger pour définir le nouveau dispositif. Entrez le nom du module: TKM (ou autre, je ne crois pas que cela change quoi que ce soit).

Cliquez sur Parcourir et rechercher libeTPkcs11.so dans usr/lib64. Valider.

N.B. : lors de votre connexion au RPVA, le mot de passe de votre utilisateur Ubuntu/Debian peut vous être demandé.

S’il demande à nouveau le mot de passe, il s’agit du code à 4 chiffres de la clé.

Choisir le second certificat proposé (le nom le plus court).

Vous êtes connectés !

Vous voilà, en principe, en mesure de vous connecter avec la plateforme E-Barreau.

retour d’expérience
  • Cela a été le cas pour moi (kiceki) de 2012 à 2018.
  • Testé et fonctionnel en janvier 2020 sur UBUNTU 16.04, UBUNTU 19.04 et UBUNTU 19.10

Interférence de dépendances

L'installation d'autres logiciels peut interférer avec cette installation et la rendre non-fonctionnelle.

Problème rencontré avec l'installation du logiciel Audacity qui remplace la dépendance libwxbase3.0-0_3.0.0-2_amd64 par une version plus récente. Seule la désinstallation du logiciel permet la réinstallation de l'ancienne dépendance.

Firefox ne se lance pas

Le logiciel Firefox peut refuser de se lancer lorsque la clef est présente. Il suffit d’ôter la clef, lancer Firefox et d'insérer la clef ensuite. Il faut probablement décharger les périphériques de sécurité issus d'anciennes installation.

  • avocats_sur_ubuntu.txt
  • Dernière modification: Le 02/02/2020, 18:27
  • par sandor szavost